[Advanced users] How to install Lineage (or any) GSI on T2e

dang thats a bummer i was hoping to test lineage 18 and a couple others before i ordered one (my daughter has the 2e) looks like there is a way to use gparted to adjust the size of the system partition you will loose a a bit on the other side though. there were some reports of this with lineage 16 also i saw. and it took simply adding 2mb to the size

so with lineage 17 can you tell us what is or is not working? does volte work? thanks

Followed directions and this is what I get… every time with different GSIs. WTF am I missing?

sending sparse ‘system’ 4/10 (262140 KB)…
OKAY [ 11.711s]
writing ‘system’ 4/10…
FAILED (remote: Operation not permitted)
finished. total time: 56.439s

Not sure. Did you revert to factory software and try again?

Yes, able to revert back to factory software every time. Still get same results with different GSIs. Are there additional steps/softwares needed that’s not in the guide? Running Ubuntu 20.04, installed latest Android Studio (SDK 11 and 10) also adb & platform-tools installation via terminal.

I read somewhere on these forums that another user who was running Ubuntu said to use Google’s adb tools instead of the Ubuntu ppas. Something about the canonical adb packages being old. Maybe try that.

1 Like

Hello everyone!
Howto fix audio jack 3.5:

  1. you have root.
  2. you have file manager with root rights.
  3. open file /etc/prop.default and add this string:


  1. Save&Reboot
  2. Profit

p.s. at least it works for me


PPA removed and installed Google’s Platform Tools. Same results.

Do you have access to a Windows 10 pc to try this out?

Thanks a ton. Other users - please post if these work for you.

Thanks, using Windows 10 does work. Tried variety of GSIs and they beautifully ran. What I noticed… the fingerprint setting seems missing even in factory software. Currently and comfortably running System Roar Arm64 AB FLOSS.

Sorry - can you clarify what you mean by fingerprint setting missing even in factory software? The fingerprint scanner works in the factory Android 10 and I think a user mentioned that it works in one of the GSI as well.

Fingerprint Scanner is not in the settings. Hence, missing in any GSI including 2e factory.

Very strange. I can’t confirm this. I used factory firmware and now I use gsi Havoc-OS-v3.12-20201230-Official-arm64-ab.img. Fingerprints works in both cases.

I’m having the same problem as Antero, also on Ubuntu 20.04 (I don’t have access to a windows PC)

writing 'system' 4/8...
FAILED (remote: Operation not permitted)
finished. total time: 59.435s

Edit: Update, i got it working with the platform tools from here

1 Like

Ubuntu Solved…
Android SDK Platform Tools for Ubuntu

1 Like

havoc 4,1 works very nicely imoas does lineage 18.1.

Is it possible to migrate FM radio app from stock to any GSI? Will it work?

It was mentioned previously that lineageos 18.1 was too big for our partition, can you provide your steps to get it working?

unlock bootloader per instructions here on the forum
fastboot delete-logical-partition product (if you get the message that says its to large)
flash system /PATH/TO/GSI.IMG
fastboot -w

had no issues this way as long as you wipe with the last command it should boot fine. headphone fix posted above did work but you do need to be rooted for that to work. you can manually adjust the size of the partition but this way works fine for me in this case. that guide is here on the forum as well for the 2e. i can write up a more detailed version tonight when i have the phone available again to me. also make sure you are using the proper lineage version for this phone and to extract the zip you download to only be the img file do not try to flash the zip file itself (some people do not know to do this) you can also use twrp if you wish also found here on the forum.



Hello, I’m a newbie and I need help.
First I installed and played with TWRP (and probably broken something).

Now when I try to fastboot flash system, I get this error:

…/platform-tools/fastboot flash system lineage-17.1-20210321-UNOFFICIAL-treble_arm64_bvS.img
Sending sparse ‘system’ 1/15 (131068 KB) OKAY [ 4.765s]
Writing ‘system’ FAILED (remote: ‘This partition doesn’t exist’)


  1. What can I do with TWRP to fix this (or flash directly) ?
  2. If it doesn’t work, how can I recreate a system partition (big enough for LineageOS 18 if possible)
  3. If nothing works, how can I reset my 2e to factory without windows (I’m using Linux)