[Advanced users only] TWRP recovery + root for Teracube 2e (1st batch, SN:2020)

The Teracube 2e TWRP as it currently stands does not support any form of encryption, whether the storage was formatted from inside TWRP or from a different recovery. You can sometimes get around this by fully disabling your screen lock and therefore encryption, but this will wipe your fingerprints and other biometric data every time you need to access TWRP in a useful fashion.

Regarding the OTA, it depends on how the /e/ OTA is signed. If they made 2e or the yk673v6 as valid device names and haven’t just locked it to Teracube_2e as the official OTA does, then you should be able to use a corresponding TWRP to perform the OTA after temporarily disabling encryption. But… as I haven’t used /e/ and tried this, I can’t say whether or not the OTA is viable.

Personally I lost TWRP access when working through fixing Magisk on my device several weeks ago. I haven’t restored it yet, but would definitely consider trying it again after a new TWRP is released, especially if it had encryption support.

1 Like

OK, thanks – at this point I have Magisk up and running with the “native” /e/ recovery installed, so I’ll probably stick with that until TWRP for 2e supports encryption.

FWIW, I could not apparently get around encryption with TWRP – I changed screen lock to “none” before I installed TWRP, but everything was still encrypted in storage, so I couldn’t install anything. I didn’t try sideload at that point, but it sounds like that wouldn’t have worked either.

All Teracube 2e editions - be it /e/OS, or iode, or stock - all can run TWRP absolutely fine. The only issue with TWRP is that encryption is pretty much dead, and that’s still a work in progress.


Sideload will work whatsoever. And if you feel like, you can store your backups to an SD Card or a USB flash drive via OTG so you can flash your backups whenever.
TWRP supports the 2e codename, so you can use that for Lineage/iode/e/any other ROM

1 Like

Yes, that mirrors my experience – was able to install/run TWRP, but couldn’t decrypt the existing /e/ OS install. Is the ability to interact with encrypted files working for other devices on TWRP, do you know?

The Magisk github location given here is deprecated. The correct location is:

1 Like

@jbray - thanks for letting us know :+1:. Link updated.

1 Like

BTW, two things: the 5-second boot delay on booting unlocked phones, presumably so one can read the unprofessional-quality message about ‘Orange’, is annoying.

Also: I can’t find any link on the site to the ‘Teracube App’.

We might work on that bootloader messaging in the future.

Is that something on the phone? Could you share a screenshot of where you see a reference to this app?

1 Like

Can anyone post as to how the bootloader message is edited? I’ve always been interested in how that splash screen can be personalized, especially to get rid of the annoying and alarmist screen that most phones default to when I’ve unlocked the bootloader myself.

The 2e that is sold by the /e/ Foundation has a very nice splash screen with “Teracube 2e” and the Teracube logo in the middle, then “Powered by Android” with a little “Bugdroid” logo at the bottom. It looks quite professional. Nothing about /e/ comes up until the OS boots. Maybe Teracube should ask /e/ about that.

1 Like

TWRP not dealing with encryption is important. As you probably know, all other recoveries are essentially useless crap in comparison. If the TWRP developers won’t do this, you should get someone to look at the decryption code for other devices and port it. As you can see from the messages, because of the removable battery and reparability, you are interesting to what we might call the XDA-Developers folks (been there for years myself: @cashmundy). Those folks will want a working TWRP and good distros available, which e and iode are currently providing.

As for the app: I saw a blue notification-link to it when I first logged back in with this new phone, accidentally deleted it and have never seen it since. The app was clearly just the website with some extra stuff like keeping my login session.

1 Like

I have a major problem. When I try to run fastboot flash recovery <twrp-image>, it says “This partition doesn’t exist”.

I tried to just install LineageOS since TWRP wasn’t working, and now the phone won’t even turn on.

I don’t understand, why is there no recovery partition? Clearly there used to be, since no one has had this issue.

How can I fix this if the phone won’t even turn on?

Hi @KavusKazian - the lineage posted here works only on the 1st batch of phones (sold in 2021). The OSS team is working on providing an updated Lineage for the new phones.

I just posted some related info here - Difference between the new 2022 batch of Teracube 2e and 2021 units

Thank you so much! Hopefully it doesn’t take too long. One of the main reasons I chose Teracube was the ease of replacing the ROM and that the hardware warranty would remain intact.


I’m not sure where to post this. Any news for TWRP for T2e 2022?

Thank you for your work and time.

TWRP for the 2e is a total joke, don’t bother with it. They had some college kid in India do it (Teracube seems to be pretty much an all-India company) who got it to where you can install it but that’s about it. He wasn’t able/couldn’t be bothered to get encryption working, so it can see your data partitions but not what’s in them and, if memory serves, can’t see an external SD card at all. Completely useless.

I installed the /e/ recovery. Doesn’t do any of the cool fancy stuff TWRP does, but it actually works. It’s really too bad the Teracube people can’t make and maintain a proper TWRP, especially since that is Team India also. It shows they have no software talent and can’t be bothered to hire any.
I think Teracube will last until Fairphone decides to sell in the USA, but no longer. If Fairphone had a USA presence, I’d buy one just for what is almost certainly good software.

Hi @jbray - want to clarify on this. Teracube is headquartered here in Redmond, WA (including myself) with an international team. Our software team is indeed based in India. And the Teracube stock OS is maintained by full time team members (not college interns). However, TWRP is an open source project and is a different story.

Hi Sharad, Don’t you think it would be a good idea for your software team, in India, to become official maintainers for a TWRP for 2e build? Judging from the github, the college kid made one build that installs but doesn’t work and called it good. If your team took his code, and got encryption working (and ext SD card if it’s broken too), you’d have a quality build that TWRP would probably accept. I know India’s a big country, but maybe someone on your team even knows someone on Team Win.
You’ve already got the encryption code working in your own stock recovery; seems like it would be a big win for moderate investment.
TWRP (when it works) is an essential tool for people installing custom roms and such, far more powerful than any stock recovery: you can pop a shell, there’s a file-manager, you can turn USB file-transfer on.


What I have heard is that TWRP is not as relevant as it used to be. Maybe I misread. I’ll check with the team and get back again.

Hi Sharad,

I hate to say it, but software-wise, you guys seem like amateurs. You’ve got an interesting little device that should really appeal to the xda-dev crowd; if you get them interested in it, you’d have a bunch of developers working on it for free, and some of those folks are really good. Of course, then it would be a global project, not just Team India.



1 Like