2e+Mint = consistently inconsistent

I can’t reliably make or receive phone calls or texts. I have Mint, but I didn’t have these issue with my Pixel 3 on Mint. The phone regularly fails to join wifi-calling and it will disconnect from wifi calling after being on for a while. I have to restart the phone several times a day to force it to join wifi calling.

How is the connectivity with wifi calling disabled?

I have no idea…how would I find out?

You can disable wifi calling by going to Settings > Network & internet > Mobile network > Advanced > Wi-Fi calling > Switch Off

My experience with Mint Mobile and the Teracube 2e has been excellent on wifi calling.