2e settings menu missing some options?

since we have 2 2e’s we can look at i happened to be trying to find a setting for one of them and noticed in the settings menu one of them is missing a few of the options. duraspeed and the google services and preferences are both missing from one of them, is there a reason for this?

That is very strange. Could you post screenshots from the one that is missing Duraspeed? Also what is your Build number at Settings > About phone > Build number?

Once you have taken the screenshot, you could try the following:

  1. Go to Settings > Apps & notifications > “See all apps”.
  2. Browse to “Settings” app. Then tap “Storage & cache”.
  3. Clear both Storage and Cache.
  4. Reboot and check again.
  5. If this does not fix it, then a reset might be required.
1 Like

sure ill get the phone from them again when i get there but i checked build numbers, and EVERYTHING matches. the phone was just reset today to factory default (they wanted to reset all the settings to start over) options still not there. i thought maybe they had been removed in later serial number as the one missing them is a newer serial number then the other one. ill get some screen shots though later today. when we saw options missing we did another reset and still options not there. maybe ill try to flash the stock rom over this one?

1 Like

build number is teracube_2e_06 also same on the other phones. when doing a reset on this phone it is super fast like takes maybe 15 seconds or so to go back to the teracube logo where when we did the one with the screen you are replacing that one took a good minute or more to reset. ill can try reflashing it with the default rom you posted here. the one with the odd screen also has the options there its only this one unit that is missing them.

1 Like

1 Like

that was after another reset we did just to test one more time which is why the uptime is so short. but i did 3 resets total. ill reflash it tonight with the rom here on the forum and see if that helps. im not that concerned about the duraspeed thing but we do want to have the google settings option back. in looking at the screen shot i also now see the digital wellbeing option is also not there

so after trying to clear storage and cache it didnt work, tried a couple more factory resets no luck. i finally went ahead and downloaded the 2e rom posted here and used spflash to reflash the entire rom and now the settings are back. maybe a corrupted install from the factory?

1 Like

Interesting - have not come across this issue so far. Could have been some corruption. Thanks for the follow up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.