[Advanced users only] TWRP recovery + root for Teracube 2e (1st batch, SN:2020)

Hi there,

now there are 4 Teracube 2e in my family and i am asking myself, how about OTA-updates after rooting the phone?
Is it planned to support that, with the regular android-updates?


1 Like

Excellent guide - I was able to root my device successfully without too much trouble. A few things I ran into:

First, I downloaded the latest Android platform tools from Google. However, I kept getting weird errors trying to use adb… it turns out that even though I was running the latest binary, I also had my distribution’s older version installed and there seemed to be some conflict there (some environment variable set wrong, or something). I completely removed the distribution-provided packages and that solved that problem.

Second, as others have noted, the vbmeta-2e-stock.img provided didn’t work and I had to extract it from the stock firmware package.

Third, after flashing Magisk, I rebooted and tried to run the app, but I got an “error parsing package” even after pushing the APK. However, I waited around 10 minutes and the app started working… I guess even after adb install finishes, it takes a while for the installation to actually complete.

Maybe this stuff is obvious to Android wizards, but hopefully it helps someone…


When I boot into twrp I can’t see my sdcard (external) or usb type-c stick. Can you confirm this? Can anyone tell me if it’s realistic to fix this?


I’m sorry i don’t have an answer to that, but isn’t it possible to just copy whatever you want to flash to the internal memory once you’re in TWRP? This has always worked for me.

Struggling with the last step (getting Magisk to launch). I’ve gone through the entire process twice and receiving the same results. I can see the Magisk app on the home screen, click on it and receive the message “Upgrade to full Magisk to finish the setup. Download and install?” I select OK but then after a couple of seconds get an error of “There was a problem parsing the package.”

Like others (@Ylvinzk, etc.), I didn’t have any success with the vbmeta-2e-stock file so used the vbmeta file from the stock firmware, but otherwise directions were followed exactly. I’ve gone through the Troubleshooting steps to no avail. Even waited 10+ minutes like @Thomas noted in his feedback.

Any help would be so appreciated! This is my first go at rooting a device and am really looking forward to learning and experimenting.

Update: Magisk manager has been merged into Magisk. Download it from github.


I would suggest you to download and install magisk manager from github.
And then follow the instructions.

Hi there it seems that after this step and before I root my device, I get the message

Carrier Services keeps stopping

fastboot --disable-verity --disable-verification flash vbmeta vbmeta-2e-stock.img
fastboot reboot

I’ve reverted to the stock vbmeta and recovery.img from the Teracube_2e_06_2020.zip but that doesn’t seems to have fixed the issue.

TWRP recovery also seems to behave weirdly with a pattern password enabled for the default android user:

  • with a pattern password present, TWRP asks to decrypt User [0] however the password for the Android user does not seem to work.
  • Disabling the pattern from the Android security settings allows me to bypass the issue

This has all happened after a bootloader unlock, factory reset, and before rooting the phone right after TWRP is flashed to recovery.

factory reset reset with 4 digit pin also seems to have the TWRP password issue.

It seems that encryption was persisting after factory reset.
fastboot format userdata finally fixed the encrypted user 0 issue.
I had been using fastboot erase userdata previously.

Still getting a flashing yellow and blue “decrypt data” prompt in TWRP that does not allow me to enter the correct password, grasping at straws here.

@Glebden, I owe you a beer! Worked like a charm!

It seems magisk and magisk manager have been merged in the latest release (v22). Wasn’t that working? Reason I ask is that downloading magisk from non-github sources is not recommended.

Not an option too - internal memory encrypted :frowning:

When you start your phone normally, you have to set it to ‘swipe to unlock’ instead of a pattern/password/fingerprint verification. (settings - security). When you have done that, reboot to TWRP and the prompt should be gone. Have you tried that?

I’ve done exactly that to create backups/restore however I have to set it to swipe everytime I want to decrypt a user in TWRP. Something I never encountered with my rooted Pixel 1.

One further issue with TWRP in addition to needing to fully disable encryption anytime you want to access TWRP is that it changes the device type (in TWRP) from Teracube_2e to yk673v6_lwg62_64 which means that official updates won’t flash, since it doesn’t pass the device verification.

1 Like

@AgentFabulous - can you check if this can be fixed?


Ahh, totally overlooked this. Will update the trees soon.

1 Like



I was able to get into TWRP, but every time I try to install Magisk I keep going into boot loops. I can’t even boot into Recovery to try to recover. I am using the TWRP-3.5.0_10-2-Teracube-2e.img file and I downloaded the latest Magisk file from GitHub.

What am I doing wrong?

I was able to root but I had troubles, especially when rebooting into recovery: I can boot to TWRP only if I reboot to recovery (keeping Vol+ pressed) immediately after the phone reboots after flashing the TWRP image, otherwise it doesn’t and it just goes to the “normal” recovery screen… While I’m looking for a way to solve this, I wrote a (I hope) more detailed guide for newbs like me :smiley: (read it @ https://www.notion.so/Teracube-2E-root-0177b0316b794bd48d5aa6c0f2d57583)

Rebooting to recovery through Magisk is how I normally get in.
ADB is another reliable path back to recovery, if you aren’t rooted.

It does bring me to the menu, but when I choose “Recovery” it doesn’t boot to TWRP
I also tried adb reboot recover and the screen I get is always the same screen

If you’re getting the ‘normal’ recovery screen, you probably don’t have TWRP anymore. Any chance you’re flashing something that is removing it, or not adding the disables (verity/verification), or something else similar?