[Advanced users only] TWRP recovery + root for Teracube 2e

Hi there it seems that after this step and before I root my device, I get the message

Carrier Services keeps stopping

fastboot --disable-verity --disable-verification flash vbmeta vbmeta-2e-stock.img
fastboot reboot

I’ve reverted to the stock vbmeta and recovery.img from the Teracube_2e_06_2020.zip but that doesn’t seems to have fixed the issue.

TWRP recovery also seems to behave weirdly with a pattern password enabled for the default android user:

  • with a pattern password present, TWRP asks to decrypt User [0] however the password for the Android user does not seem to work.
  • Disabling the pattern from the Android security settings allows me to bypass the issue

This has all happened after a bootloader unlock, factory reset, and before rooting the phone right after TWRP is flashed to recovery.

EDIT:
factory reset reset with 4 digit pin also seems to have the TWRP password issue.

EDIT2:
It seems that encryption was persisting after factory reset.
fastboot format userdata finally fixed the encrypted user 0 issue.
I had been using fastboot erase userdata previously.

EDIT3:
Still getting a flashing yellow and blue “decrypt data” prompt in TWRP that does not allow me to enter the correct password, grasping at straws here.

@Glebden, I owe you a beer! Worked like a charm!

It seems magisk and magisk manager have been merged in the latest release (v22). Wasn’t that working? Reason I ask is that downloading magisk from non-github sources is not recommended.

Not an option too - internal memory encrypted :frowning:

When you start your phone normally, you have to set it to ‘swipe to unlock’ instead of a pattern/password/fingerprint verification. (settings - security). When you have done that, reboot to TWRP and the prompt should be gone. Have you tried that?

I’ve done exactly that to create backups/restore however I have to set it to swipe everytime I want to decrypt a user in TWRP. Something I never encountered with my rooted Pixel 1.