APN / MMS T-Mobile

I have t-Moble and I can not send photos via my txt messaging. I can receive photos, but can not send. Any Ideas…

1 Like


Sorry for the trouble.

Have you verified your phone’s current settings against T-Mobiles documentation for APN settings?

  • Name: T-Mobile
  • APN: Fast.t-mobile.com (for LTE devices) or epc.tmobile.com (for non-LTE devices)
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • MMS proxy: <Not set>
  • MMS port: <Not set>
  • MMS protocol: WAP 2.0
  • MCC: 310
  • MNC: 260
  • Authentication Type: <Not set>
  • APN Type: default,supl,mms OR Internet+MMS
        Default Android provides a text field to enter: default,supl,mms.
        Samsung provides an Internet+MMS radio button to select.
  • APN Protocol: IPv4/IPv6
  • APN roaming protocol: IPv4/IPv6 or IPv4 only when roaming internationally
  • Turn APN on/off: Grayed out unless there are multiple APNs
  • Bearer: Unspecified

The only thing different is Bearer. I have:

1 Like

X BYOD T-Mobile data & APN settings | T-Mobile Support

1 Like

What messaging app are you using? Does it throw an error or give you any indication what is happening?

Some of the messaging apps do a poor job of resizing content to meet the MMS file size limits of the various carriers. The best-behaving app I’ve seen in this regard is Google Messages. Would you be willing to give that a shot for an outbound message test?

I have TMobile and recently started having the same issues. I’m using messages.android_20230110_01_RC00.phone.openbeta_dynamic

I also tried Pulse, Messenger and Mood, all with same issues. Sometimes switching off and back on Mobile data/WiFi helps, but pictures take forever to be sent or being received.

1 Like

This is the error message:

1 Like

Do you experience problems on the Stable channel of Messages as well?

Yes, stable or beta, same issues.

1 Like

Are your APN settings correct as per T-Mobile documentation?

Have you enabled any other features or changed the APN settings before this issue began?

As far as I know, yes.
I haven’t messed with the APN settings before the issues started

1 Like

Can you please try resetting them from the triple dot menu in the upper right?

1 Like

I did. It’ll work for some time then I’d have to reset it again

1 Like

I know this is of little consolation, but I’m experiencing similar on ATT/CricKet on all our units in my house. It began after ATT started to decommission 3G towers in our area last year to spin up more 5G.

I usually just toggle airplane mode once a day out of habit now -_- Should probably find an app to do that overnight for us.