Certain Notifications Missing

I’ve had the 2e for a few months now, and have noticed that there are certain apps that I never receive notifications for. I’ve tried the following for each app, to no avail:

  • Turned notifications and allow notification dot on in Settings → Apps & Notifications
  • Disabled battery optimization
  • Confirmed notification settings within each app are correctly set

Additionally, I am not using a task killer app. I’ve used all of the impacted apps before on other devices without having problems getting notifications. Wondering if anyone has had similar issues and been able to find a solution.

1 Like

I’ve had the same issue, particularly with the Ring app. I am only able to receive notifications if I manually open the app and leave it running in the background. My wife has the same problem with her 2e as well.

Could you try the recommendation in this thread. Basically

  1. Disable battery optimization for whatever app is missing notifications.
  2. Enable Duraspeed and whitelist all apps or the apps having issues.

Here’s another discussion on this topic.

Totally missed those threads, sorry. Just finished making those changes. Will report back on results.

This appears to have solved the problem for ProtonMail.

1 Like