Do Not Disturb schedules do not work overnight

I want to set up a Do Not Disturb schedule to automatically turn my phone on Do Not Disturb mode before bed and then automatically turn it off in the morning. For some reason it never works.

When I set a DND schedule to start in one minute and end five minutes later, it begins and ends when expected. When I change it to begin in one minute and end at 7am following morning, it also begins when expected (though I didn’t wait until the next morning to check if it ends because I don’t want my phone on DND mode all day long). But for some reason when I change the begin time to be 8pm and the end time to 7am, it stops working: it fails to turn on at the set start time, and if I turn on DND mode manually, it doesn’t turn off at the end time. It doesn’t appear to matter whether the phone is unlocked or not at the time the DND schedule begins.

These are the settings I am using:

  • Days: all selected
  • Start time: 8pm
  • End time 7am next day
  • Alarm can override end time: turned on
  • Do Not Disturb behavior: Use default settings

Again, the only difference between when it works and doesn’t work is setting the start time to be 8pm. I didn’t even create a different schedule for testing and my desired night time schedule; I just changed the times for the existing one.

I’m on a Teracube 2e on Android 10. My phone says it’s up to date. If you need any more info from me or want me to try anything else, let me know.


1 Like

Sorry to hear this!

I’m having a hard time following and want to replicate it exactly, so could you please provide screenshots of your setup?

@Saijin_Naib Here’s a screenshot of my settings:

I also have an update: Last night I had the “Night time” schedule above set to begin at 8pm. That time came and went and once again, DND mode did not turn on. At around 8:31pm I opened the settings and changed the start time to 8:35pm. This time, it did turn on at 8:35pm as expected. Also, this morning I was using my phone around 6:30am, and at 7am DND mode turned off as it should. So my theory is that if the phone has been used recently, the schedule will work. On the other hand, if it’s been a while since the phone was used, it’s almost as if the DND schedule “goes to sleep” if you will, and misses the time it’s supposed to turn it on or off. At least, that’s how it looks anyway.

I know that DuraSpeed has been mentioned in the past as a potential culprit to some of the issues 2e has been having, so I turned that off completely quite some time ago, but the issue still occurs. I’ve also heard that battery optimization can cause some apps to not perform scheduled tasks. If so, I’m not sure which app would correspond to DND schedules in order to disable optimization for that one. The issue also persists after restarting the phone, and even after getting a brand new phone (I recently had my phone replaced for a completely separate issue, but this issue occurred on both devices).

Let me know if there’s anything else I should try. Thanks.

1 Like

Are you able to turn duraspeed on and add all apps to it so they are allow-listed? Counter-intuitively, this can work better than disabling duraspeed.

I hadn’t tried that before. I’ll try it now and report back.

1 Like

I just recently came across this guidance when investigating low reliability of notifications in Threema, and their documentation suggests this fix.

It does indeed seem to help :person_shrugging:

I tried it, and unfortunately the DND schedule still did not work. It did not turn on or off when it was scheduled to do so. (After it failed to turn on, I turned it on manually, and then it failed to turn off as well.)

The next thing I plan to try is have my phone unlocked and in use at the time the schedule is supposed to start/end to see if that has any effect. If you have any other ideas of what to try, let me know.

1 Like

Unfortunately I’m back to square one.
I tried having my phone unlocked at the time the schedule was supposed to begin/end, and that didn’t seem to have any effect. The only thing that seems to allow the DND schedule to turn on is to set the start time to be only a few minutes ahead of the current time, but that obviously kind of defeats the purpose; I might as well just turn it on and off manually in that case.

In short, I still don’t know what contributes to the DND schedule not working.

1 Like

I’m going to try and reproduce and debug this behavior here, as well.

Can you please confirm what OS version you have installed?

Android 10. I just checked for updates, and it says I’m up to date.

1 Like