Does Waze work well on your 2e?

I use Waze daily on my iPhone, but I have not been able to get it to work well on my new 2e.

PROBLEM: The Waze map always trails actual road position by a long distance. When coming to a stop, it can take Waze as much as ten seconds to catch up. Voice directions always occur after the required turn has passed.

TESTS: The GPS receiver seems to be working well according to an app called ‘GPS Test’. I tried several apps claiming to improve GPS performance (GPS Aid, GpsFix, and ActiveGPS) and none make any improvement in Waze performance.

I would greatly appreciate if anyone can tell me if my 2e is faulty or if all persons are having this problem with Waze.

1 Like

Have you tried Google Maps for navigation?

Waze relies heavily on Data. Google bought wazes and has been adding features from wazes to Google maps.

Google maps will pre load and not as reliant onbdata service.

Google maps lacks the desirable crowd sourcing feature of Waze. It does seem like Waze has become a bloated app that may be just too resource hungry for the processor in the 2e.

What I am looking for is input from other 2e/wazers that I am not looking at a hardware problem on my 2e.

1 Like

Hi @kolinahr - could you try the same experience on Google maps? This will tell us if its the waze app or the hardware.

1 Like

I discovered what appears to be a solution, or at least a workaround for my problem. By default there are two apps that use location data even when they are not open. They are “Google Search” and “Google Maps”. Change the setting for Google Maps to “Only while using the app” seems to remove the congestion that was keeping Waze from running properly. Afterward, I completed five Waze routes without a single problem.