Doesn't power on

I was attempting to flash eOS and LineageOS, and fastboot was giving errors about partitions not existing

+ fastboot flash recovery recovery.img
target reported max download size of 134217728 bytes
sending 'recovery' (32768 KB)...
OKAY [  0.814s]
writing 'recovery'...
FAILED (remote: This partition doesn't exist)
finished. total time: 0.822s

the fastboot -w command gave an error about ext2

wiping userdata...
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-BRhg5c: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

So I tried to flash stock via SP Flash tool, I got to the step to click the Download button, and it said to reboot the phone, and after that it doesn’t do anything. No fastboot, no bootloader, not detected by the computer. It doesn’t power on anymore.

I tried something else and booted into Windows. Performing the following, I was able to get a little further:

  1. Unplug phone from computer
  2. Pull battery
  3. Start up SP Flash and set it up with the scatter on the Download tab.
  4. Click download
  5. Reinstall battery
  6. Plug phone into computer.

SP Flash then proceeds to flash the phone, working through several partitions, all the way through to the checkmark dialog box.

Still no life from the phone though, no fastboot, no bootloader, no recovery. Nothing appears on the screen. I do notice that when plugged into the computer, a Preloader device and a COM port device do show up in Device Manager on what appears to be a timed cycle.

Few things to check:

  1. Did you hold the power button long enough? Sometimes it take 10-20 seconds to power on.
  2. Does the battery icon come up when you plug in the charger? If yes, how much percentage of battery life does it show? Maybe it needs to charge up for few hours.

Please check after charging for few hours.

  1. I held the power down for 60 seconds, no activity from the phone.
  2. The battery icon does not come up on the screen. I noted also that the charging LED indicator also doesn’t illuminate.

I’ve left it plugged in for up to a couple of hours prior to testing it. I’ll leave it plugged in over night to see if it makes a difference.

I also tried to boot to recovery, and fastboot via Vol +/- while holding the power button. No life.

ok, let us know how it goes after charging overnight. If nothing, your unit might need a warranty replacement. Please email in that case with a link to this thread.

After being plugged in over night, still no change, doesn’t power on. It feels like it’s just a single command or action away from working correctly since it flashes with SP Flash correctly and without error.

I’m going to email support to see if anything will come of that.

Also, I don’t seem to be able to edit my original post, but I have some corrections. Since discovering that Windows detected the preloader, and COM port devices, I checked again in Linux, and found that the computer does detect these devices correctly as well:

[128091.186181] usb 3-3: new high-speed USB device number 9 using xhci_hcd
[128091.340295] usb 3-3: New USB device found, idVendor=0e8d, idProduct=2000, bcdDevice= 1.00
[128091.340297] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[128091.340298] usb 3-3: Product: MT65xx Preloader
[128091.340299] usb 3-3: Manufacturer: MediaTek
[128091.407949] cdc_acm 3-3:1.1: Zero length descriptor references
[128091.407954] cdc_acm: probe of 3-3:1.1 failed with error -22
[128091.447994] cdc_acm 3-3:1.0: ttyACM0: USB ACM device
[128094.056838] usb 3-3: USB disconnect, device number 9
[128097.374157] usb 3-3: new high-speed USB device number 10 using xhci_hcd
[128097.528294] usb 3-3: New USB device found, idVendor=0e8d, idProduct=2000, bcdDevice= 1.00
[128097.528295] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[128097.528296] usb 3-3: Product: MT65xx Preloader
[128097.528297] usb 3-3: Manufacturer: MediaTek
[128097.583948] cdc_acm 3-3:1.1: Zero length descriptor references
[128097.583952] cdc_acm: probe of 3-3:1.1 failed with error -22
[128097.623981] cdc_acm 3-3:1.0: ttyACM0: USB ACM device
[128100.231935] usb 3-3: USB disconnect, device number 10

I also found that SP Flash Tool will also flash the phone just as well in Linux, behavior is exactly the same, however, flash tool must have the necessary permissions to access the USB device. An easy way to do this is to sudo ./ It then proceeds to flash the phone without error, just as it does in Windows:






vid is 0e8d

device vid = 0e8d

pid is 2000

device pid = 2000

com portName is: /dev/ttyACM0

Total wait time = -1647264437.000000
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
USB port detected: /dev/ttyACM0
BROM connected
Downloading & Connecting to DA...
connect DA end stage: 2, enable DRAM in 1st DA: 0
DA Connected
executing DADownloadAll...
[0] WRITE TO PARTITION [ preloader ]

[17] WRITE TO PARTITION [ logo ]

[18] WRITE TO PARTITION [ md1img_a ]

[19] WRITE TO PARTITION [ spmfw_a ]

[20] WRITE TO PARTITION [ scp_a ]

[21] WRITE TO PARTITION [ sspm_a ]

[22] WRITE TO PARTITION [ gz_a ]

[23] WRITE TO PARTITION [ lk_a ]

[24] WRITE TO PARTITION [ boot_a ]

[25] WRITE TO PARTITION [ dtbo_a ]

[26] WRITE TO PARTITION [ tee_a ]

[27] WRITE TO PARTITION [ vbmeta_a ]

[28] WRITE TO PARTITION [ vbmeta_system_a ]

[29] WRITE TO PARTITION [ vbmeta_vendor_a ]

[39] WRITE TO PARTITION [ super ]

[43] WRITE TO PARTITION [ userdata ]

download speed: 35.37MB/s.
Download Succeeded.

With this new info, the phone still doesn’t power on, but IS detected by computer.

So, support wasn’t any help as they just wanted to replace it. So, I just did a little more digging and found a way to unbrick it myself. The device was only in a soft brick state, as I thought.

Since everything with flashing is working correctly and all of the partitions have been flashed with the stock image without error, there was only a couple of things missing which I discovered through some reading and exploration.

The issues were:

  1. The device was trying to boot to “slot b.”
  2. No means to switch to slot a since the device doesn’t turn on to boot to fastboot.

I encountered this bit of information on the thread for the LineageOS work. I suspected that this was the issue, but didn’t confirm it until I was able to figure out how to boot the phone into fastboot mode.

The phone doesn’t power on via the power button, however, I discovered that there is a second way which is actually very similar, but only realized it was happening until I happened across a forum post on XDA which mentioned it in passing, in combination with looking at dmesg output when performing the procedure. To boot the phone into fastboot mode, even though it doesn’t power on with the power button:

  1. disconnect phone from computer
  2. Pull and re-install battery
  3. hold Vol Up (or Down?)
  4. plug the USB into the computer

The removal of the battery isn’t necessary, however, it eliminates the possibility that the phone is in a powered on state unknowingly since nothing is displayed on the screen.

I’m not sure if step 3 should be Up or Down as I only did this once, and I may have accidentally held down Up, Down, or both as I heard both buttons click. I immediately continued on to the next step once I realized it was in fastboot mode. That being said, the procedure can be performed trying either each time.

The device should boot to fastboot mode and show like this in dmesg

usb 1-4: new high-speed USB device number 7 using xhci_hcd
usb 1-4: New USB device found, idVendor=0e8d, idProduct=201c, bcdDevice= 1.00
usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-4: Product: Android
usb 1-4: Manufacturer: MediaTek
usb 1-4: SerialNumber: 202111T2EXXXXXX

Note that the Product is “Android”, and the SerialNumber is displayed.

At this point, nothing was displayed on the screen, but the phone was indeed in fastboot mode.

It should also show the device identified by the serial number via fastboot.

$ fastboot devices
202111T2EXXXXXX	fastboot

Now that it’s gotten this far, we can set the slot to boot to via fastboot:

$ fastboot --set-active=a
Setting current slot to 'a'...
OKAY [  0.013s]

I wasn’t sure if it would work or what, but I then booted it to the bootloader:

$ fastboot reboot bootloader
rebooting into bootloader...
OKAY [  0.003s]
finished. total time: 0.053s

The screen now turned on, and displayed the FASTBOOT prompt. So, even though this is the “bootloader” it’s still some kind of fastboot mode, so since we have a screen now, I felt comfortable booting into system and leaving fastboot.

$ fastboot reboot

finished. total time: 0.050s

It then rebooted, and showed the Teracube logo, and then continued to boot into the first boot setup.

After all of this, I’ve tried to verify the steps to redo the procedure to boot to fastboot mode without success. I can only guess as to why they don’t work now after switching to slot a. I’m guessing that Vol Up/Down boots to a specific partition when held down as the device powers on, and when using slot a, that partition now doesn’t have the fastboot code on it. Now when performing the steps above, it just always brings up the Preloader instead. I’m not keen on switching back to slot b, or trying to brick the phone again to confirm this.

I wish the documentation was better, or existed at all so we could actually understand what’s happening inside the device rather than just experimenting and guessing about it, and posting our findings on a forum on the Internet.

P.S. the battery isn’t required for working with the SP Flash Tool. So the battery related steps that I included in my first post aren’t necessary.

1 Like