Error updating E/OS

This may be a better question to ask in an E/OS forum, but since I don’t know of any off the top of my head I figured I’d try asking here first.

I have a Teracube 2E ordered from the e foundation with E/OS already installed. I periodically got update notifications and installed them a couple times, the last of which was 1.0, I think last spring. Never had any issue with an update.
Yesterday I got a notification that there is an update and when I went to install it it said it was version 1.7 and had the date 2/10/23. I tried to install anyway, but when it restarts it’s in Recovery Mode. There are a few options: Reboot system now (restarts without updating), Apply update, Factory reset and Advanced.
Then it says “E: footer is wrong
Update package verification took 0.0s
E: signature verification failed
E: error: 21
Installation aborted”
Other than reboot system now I haven’t tried the other options because that seems above my head. Curious if anyone else has had the same issue? Or knows if it’s alright to choose Apply Update to see if that is all it takes.

I’m also wondering why I didn’t get any notifications about updates 1.1-1.6 and if that has something to do with why it isn’t working?

If anyone has ideas or suggestions of better places to ask I’d be happy to hear them!


1 Like

I’d probably just go ahead and backup what you have and run the easy installer for it. Try the Easy Installer beta

1 Like

Thanks for that tip, I hadn’t heard of the Easy Installer before. I’ll give it a try tonight. Is there an easy way to backup my phone that I’m oblivious to? I’m not very current on cell phonethings and haen’t ever backed one up before embarrassed face

Thanks for the help,

1 Like