How to install LineageOS 17.1 GSI on the teracube 2e

NOTE: These instructions only work for Teracube 2e sold and shipped in 2021. They do not work for the 2022 batch yet. Read more here.

- How to install LineageOS 17.1 GSI on the teracube 2e -

NOTE / WARNING - This procedure will delete all files / user-data from the phone. If you have data, photos, apps, etc, on the phone, that you care about, you will need to back it up before performing this procedure. Unlocking and reflashing always carries the risk of bricking a device - please proceed with caution, especially if this is your primary phone. These instructions are for Windows 10, but a similar process can be used to flash the phone in Mac or Linux. Emergency recovery instructions are linked at the end of this post.

Thanks to these forum/team members for helping me flash LineageOS back in March (the first time I ever unlocked/flashed a phone) and a bit of copypasta:

@Sharad - @Robert - @Jake

Things you will need:
- teracube 2e device with charged battery
- Windows 7/10 PC and USB cable to connect teracube 2e
- Latest LineageOS 17.1 GSI (Generic System Image)
- 7zip or similar tool to decompress the GSI
- Android platform-tools

1.) Download 7zip (if necessary) and Android SDK platform-tools:
7zip tool - Download and install -

Android SDK Platform-Tools kit -
Download and unzip to a folder - I used C:\platform-tools.

2.) Download LineageOS 17.1 GSI:

LineageOS 17.1 is Android 10 based. LineageOS 18.1 is Android 11 based. I have not tested 18.1, but the installation process should be identical.

For the teracube 2e, you will need to download the Treble Arm64 bvS GSI.
As of 26 July 2021, “lineage-17.1-20210714-UNOFFICIAL-treble_arm64_bvS.img.xz” is the latest LineageOS 17 build. This version will increment as fixes and security updates are rolled out, but will always be based on Android 10.

3.) Decompress the LineageOS image:
Use 7zip, WinRAR, or similar tool to decompress the LineageOS image file. Copy the image file into the platform-tools folder (C:\platform-tools).

4.) Unlock the Bootloader and enable Fastboot:
Enable Developer Options, OEM Unlocking, and USB Debug -
If Developer Options is not available go to Settings → System → About and tap Build Number ten times.

  • Enable OEM Unlocking - Settings → System → Developer Options → OEM Unlocking
  • Enable USB Debugging - Settings → System → Developer Options → USB Debugging
  • Reboot the phone (maybe not necessary, but I did)

Enable Fastboot -
Connect the teracube 2e to the PC with the USB cable.
Open a Command Prompt window in Windows - Press Windows-R, type cmd and press enter.
Navigate to the platform-tools folder - For me, this is C:\platform-tools -
Type cd c:\platform-tools and press enter.
–Pro-Tip-- Pressing TAB in the command prompt, while typing a filename, will auto-fill from files in the current folder (or system PATH). Press TAB again to cycle to the next filename, in alphabetical order.

At the Windows command prompt, type adb reboot bootloader and press enter. The phone should now reboot into Fastboot mode.

Unlock Bootloader -
Type fastboot flashing unlock and press enter. The phone will display a confirmation message - press VOL+ to accept. The bootloader is now unlocked. You will see a message during the boot sequence each time you boot/reboot your phone - “Orange State” - this is an expected behavior.
Enter Fastbootd -
At the Windows command prompt, type fastboot reboot fastboot and press enter. The phone will reboot again.
At this point, your Windows command prompt should look like this (except you’re probably not Bill):

5.) Flash LineageOS 17.1:
At the Windows command prompt, type fastboot flash system
Substitute with your LineageOS image file name.
Press enter to begin the flash procedure - this takes approximately 135 seconds and results in the following output in the Windows command prompt:

Reboot and System Recovery:
On the phone, select Reboot system now and tap the power button. The splash screen will present the “Orange State” warning (it will be longer than the 5 seconds indicated).
Complete the LineageOS initial setup - you can skip setting the PIN, etc. You’re going to be doing this initial setup a second time.
A Factory Reset is required to prevent random android.process.xxxx errors, or other potential issues -
Settings → System → Advanced → Reset Options → Erase all data (factory reset)
The phone will reboot back into the LineageOS initial setup routine. After this process, the OS Installation is complete! The first thing I did was connect to the internet and download/install the F-Droid APK -

Need to revert to the teracube 2e stock Android image?:


If anyone had feedback to improve, please let me know. I plan to make some minor formatting changes, particularly to make the command line entries more clear and uniform. Thanks in advance!

Hi Sampson,

Thanks for the guide. I was able to install LineageOS on my Teracube 2e by following your steps except for fastboot flash system [my_lineage_img], I encountered the following error:
Resizing 'system' FAILED (remote: 'Not enough space to resize partition')

The solve it, I simply ran the command fastboot delete-logical-partition product and ran fastboot flash system [my_lineage_img] afterwards.

1 Like

I have tried this using the latest version of fastboot, but I still get the same error below:

Sending sparse ‘system’ 1/10 (131068 KB) OKAY [ 3.110s]
Writing ‘system’ FAILED (remote: ‘This partition doesn’t exist’)
fastboot: error: Command failed

Any thoughts?

Are you using fastbootd instead of fastboot?
On the Teracube 2e, regular fastboot only flashes to whole partitions, not logical partitions, which are system, vendor and product. This is due to having dynamic partitions in place.
I would like you to run this first -
fastboot reboot fastboot
And then run whatever fastboot command you wanted to.