Is my SIM2 slot in my Teracube 2e faulty?

I am on vacation in the USA and checked to make sure that I could use an AT&T SIM in the SIM2 slot in my Teracube 2e phone. All information to the positive, I bought and installed the SIM. In the shop where i bought it, we got it working, it took phone calls, and for about half an hour afterwards it worked fine - I sent multiple test messages (SMS) out to contacts to advise my new US number.

The battery died and I put it on to charge. Since the phone has been turned off, it is no longer registering the AT&T SIM - in either slot - while it readily allows me to use the Vodafone SIM that I’ve been using at home in Australia without any hassles. (The Vodafone SIM worked in whichever slot I used.)

I don’t think it’s the hardware, and since the connection worked while I was in the store (I sound like someone taking a car in for a repair - “It wasn’t working before I brought it in here to be repaired!”) I don’t think it was the SIM itself.

Thoughts, help, anyone?

Hi @redearthman74 - apologies for the late reply. Did the AT&T sim work anymore? I’ll suggest few things:

  1. Call AT&T customer service to see what’s going on.
  2. See if the SIM works in another phone.
  3. If it still doesn’t work, get one of TMobile-based SIMs. We have few affordable ones in this list (like MetroPCS, Simple Mobile, and Tello).

Hi Sharad,

I subsequently went to a different AT&T store and was served by the youngest staff member in the organisation (felt like). I explained the problem as I saw it, he simply fetched a new SIM, changed the phone number from the one that wasn’t working to the new SIM and we tried it out. It worked - works - perfectly. I haven’t had any further issues.

Thank you.

1 Like

Glad that it worked out in the end.