Linux USB file access

So there seems to be a problem with the permissions settings when connecting to a computer through the USB port.
First off, while connected the screen flickers unacceptably.
Second, android doesn’t ask me for permission to let my computer see my files, thus I cannot access my phone files through the USB.
Third, there are no settings options for setting up the USB port, and telling Android how to manage the USB port while connected to a computer.

Wen I connect to the computer, I get a notification in the pull-downs, that says
“Android system - Charging this device via USB” and an “expand down” mark

If I expand that notification, it adds “Tap for more options”
that takes me to “USB Preferences”
first toggles are
“USB controlled by”

  • Connected device
  • This device (defaulted)

“Use USB for”

  • File transfer
  • USB tethering
  • MIDI
  • PTP
  • No file transfer (defaulted)

You can also get to it by Settings> Connected Devices> USB, but the notification will get you right there.

Hope this helps!

1 Like

Thanks, I all ready saw that option. But all options are greyed out. Not selectable.

ok I think that there is the problem, because that is where I change it.

Could the cable be providing charging but not data transfer?

Are you connecting it to Windows 10 computer? Anything special on the computer side or on the phone?

Google gave few suggestions:

    1.1 Try a difference cable
    1.2 Try a different port on the computer
  2. - this one is taking to Developer options and setting default USB connection type to File transfer.

One thing I may suggest is to ensure your computer (Linux or Windows) has the correct USB driver installed.

For Windows, make sure you have the right driver installed by checking it via Device Manager, as shown below.


I am using Linux.
I can connect flawlessly to my Samsung s8+.
I have 3 different USB c cables, they all have the same result on the teracube phone. All three work perfectly on the s8+.

All three cables also cause horrible screen flickering while connected to the computer.
Yet no flickering when plugged into wall charger.
I get no flickering on my s8+ while plugged into the computer.

What version and variant of Llnux (Ubuntu, SUSE, Fedora, etc) are you using? I can try to see if I can reproduce your issue from our office and see.

I’m using Linux mint 19.3.

I just installed Linux Mint 19.3 64-bit Cinnamon version (linuxmint-19.3-cinnamon-64bit.iso) on a laptop. I connect Teracube with the USB-C cable that came with the unit and I was able to access the files on the phone seamlessly. I tried it on two separate units (my own Teracube and one of the test units) and both work just fine.

Were you able to get the file access working on your Linux Mint? If not, is it possible for you to test your Teracube with Windows 10?

I was able to access it by way of a second computer that had mint 19.2 on it. I was not able to get it to connect with the first computer that has mint 19.3.

So it’s probably my computers problem, not the phone.