microSD Filesystems

My previous phone only allowed FAT32 (which can’t handle individual files that are larger than 4 GiB), and it was a bit of a hassle to arrange my files so that all the >4GiB ones were on internal storage. When I had my new Teracube reformat the card, it came out as what appears to still be FAT32, but I’m not sure if this is a limitation of the phone or if it was merely following the lead of the card’s current filesystem.

Is there a way to format the card in such a way as to accept large files, while still remaining compatible with the Teracube 2e?

What size is your card?

Most operating systems will default to FAT32 for volumes smaller than 40GB or so.

If you have a computer, you can force it to exFAT. Mac and Linux can have some vagaries with how they format exFAT, so I recommend creating new volumes on Windows 10.

It’s 256GB. (I know the official limit is 128GB, but I’ve seen many reports on this forum that larger cards do work, and I know that in general any microSD reader that supports 64+ GB will handle up to 2 TB.)

I just tried using Windows 10 to format the card as exFAT, and when I put it back in the phone and booted the phone up, the phone complained of an issue with the card and told me I would need to format it before it could be used. When I accepted, the now Teracube-formatted card went back to rejecting attempts to copy a 5 GB file into it.

I suppose I could try ext4? I don’t need Windows compatibility: my laptop use is almost all Ubuntu.

Android is usually pretty slim on what FS drivers are in kernel.

Should have FAT and exFAT, maybe F2FS as well. Try that over ext4.

I tried both, and they gave a different error message than the exFAT did: rather than complaining of an “issue” with the card that needed to be “fixed”, the phone explicitly said the format was unsupported.

(I suppose the next thing to try would be formatting it as exFAT using a method other than the Windows 10 default method, but I’m not sure how to do that. The exFAT option was greyed out on GParted.)

I figured out how to format the card as exFAT on Linux (the fact that exFAT had given a different error message than the others made me wonder if maybe that formatting really had gone wrong). It didn’t help: gave the same “issue with card, tap to fix” error as the first exFAT attempt.

I was looking forward to not having these FAT32 limitations anymore, but at least I’m experienced at working around them. I’ll go arrange my file organisation system to put all large files on internal storage, and I saved a copy of the APK for the last fully-FAT32-compatible version of Kiwix which I should be able to sideload.

(…if it’s a kernel issue, does that mean it would be possible for the devs to patch support in later? I’m accustomed to WYSIWYG smartphones with zero aftermarket support and not used to thinking in these terms.)

Yeah, in theory they can include other FS drivers.