Mobile data with /e/ on T2e?

I’ve only had my Teracube 2e (from /e/) for a few days, but haven’t gotten Mobile Data to work yet. Since this post is nine months old, I want to make sure these are still the steps to follow to try to get it working. I’ll try these if that’s what it takes, but if a better way has been learned since last May I’d rather start with that :slight_smile:

Hi @Plural_porcupine - which carrier are you using? The steps should be similar for our stock firmware and /e/ (however I have not used /e/ myself yet). Here are few things you can try:

  1. Try the SIM card in your 2nd SIM slot.
  2. Reboot the phone.
  3. Make sure the SIM works in some other phone.
  4. Ask in /e/ forums as well.
  5. Reply here with your carrier info.

Sorry, I meant to include that. I’m using Mint Mobile, which I think should be totally compatible.
I switched the SIM card to the 2nd slot and that did seem to make a difference, because once I did that I got a text message from Mint with instructions to follow to set up data and picture messaging and to follow the instructions given here:

It seemed to be going smoothly, but after finishing Step 7 and hitting Save, the only message I see on the APNs screen is “Access Point Name settings are not available for this user”

Do you know how I can get around this? I’ll try contacting Mint customer support when they’re open tomorrow, but this seems like it’s more of an issue with the Teracube than Mint, to me.

Maybe there’s a setting I can change so that I can set Access Point Names? :person_shrugging:

Personally I never had problems with mobile data on tmobile, and mint runs on tmo. You should be able to change apn in Sim card settings.

How do I get to the SIM card settings? I’ll try to change them, if I can figure that out.

@Sharad I talked with Mint, but they told me “The reason your device is not able to work is because the phone is Network Locked, let me explain… This means that your previous carrier or the store where you purchased the device are preventing you from using another service provider. You can fix this very easily by reaching your carrier and requesting the unlock, further assistance should be provided by them” I didn’t have a carrier before Mint mobile, so I’m hoping there is a way for Teracube to release the Network lock so I can get this issue fixed.
Let me know if you know of anything I need to do to help.

Apn settings are:
Network and internet
Mobile network
(Your sim)
Access point names

Hit the + on top and enter a new apn like this

As far as Mint saying the phone is locked, they’re wrong. They’re just grasping at straws because they don’t know what else to tell you.

1 Like

Alright, those are the instructions I tried following. I hit the + and entered & saved a new APN, but afterwards it still didn’t show up and only said “Access Point Name settings are not available for this user”

I’m not sure if Mint is right about the Network Lock issue, I’ve never heard of it before, but it may be a thing. It also might be something that /e/ did, I am trying to see if they can help me also.

If I can get this sorted out, it will be great. Right now I feel like I only have a phone that’s really useful less than half the time. which is…not great.

Very odd. I was able to add the APN without issue.

What version of e are you running? Settings, about phone, build number
Mine is:
e_2e-userdebug 10 QQ3A.200805.001 eng.root.20220122.012327 dev-keys,stable-release

There’s nothing I’m aware of that would allow any provider’s SIM card to lock your (factory unlocked) phone to then only use their network.

@icantremember I’m not super knowledgeable about cell phones, but I’m definitely at a loss. I took a screen shot of the APN screen/message I get when I try to add the APN, this is also what I see after I click the + and enter the Mint Mobile APN settings.

I tried with the initial version of /e/ that it was shipped with as well as with the January update: 0.021-20220122158537. I got the same message with both versions of /e/ “Access Point Name settings are not available for this user” and also before and after doing a factory reset. I haven’t gotten mobile data to work with any version.

I’m using the SIM card that Mint Mobile sent me and don’t know where I would even get another one to try to see if that is somehow the issue.

I ordered my phone from /e/ and I’m starting to think I’ll have to send it back to them. I’ve talked with customer support from Mint Mobile, /e/, and Teracube and tried everything that each person has asked me to do and I’m still not even sure if this is a problem with /e/, the Teracube or Mint Mobile, which makes it hard to try and solve.

So far, you’ve probably been the most helpful of anyone. I’m going to try a little longer to see if I can figure out how to make the Access Point Name settings available, because it will cause some difficulties to not have a mobile phone while /e/ tries to sort it out. I’m not sure where else to look for ideas though!

Really weird. Do you have another SIM in the other slot?

Do you have another phone to try this sim on?

I see one instance of this online (samsung phone) where the user eventually got a new sim and it worked the way it was supposed to.

Kinda at a loss here.

I only have one SIM card in the Teracube and it’s the one that was sent from Mint Mobile. I’ve only used it in the Teracube, so I can’t say if it works 100%.
I still have my previous cell phone, with an older SIM card. That was previously used with a different carrier (Boost Mobile) that didn’t support Teracube, so I let my account expire.

Would I be able to learn anything from putting the SIM card I used with Boost Mobile in the Teracube, or vice versa?

It also seems like some people have been able to solve this problem by making sure their phone connects to WiFi when it starts: How to Fix APN Settings Not Available for the Current User Profile. This solved the problem for someone else using /e/ on a Teracube about a month ago.
I’ve connected the Teracube to my home WiFi and thought I had it set to connect automatically on startup. But after checking and reconnecting, I realized that it requires me to enter my WiFi password every time the phone is turned on to connect to the WiFi.

I’ve re-entered the password, clicked on Save, restarted my phone but it doesn’t connect to the WiFi automatically and requires me to enter the password again to connect to the internet.

Any ideas about what I’m doing wrong? It’s as if I’m not actually saving the password, but since I clicked Save, I’m guessing there’s something else I’m missing.

I don’t even know if this will fix my mobile data/APN issue, but I’d like to rule it out before I do anything more drastic, like send my phone back to /e/.

Hi @Plural_porcupine - lets make sure that the SIM card is good:

  1. Try the SIM card in 2nd SIM slot of the 2e.
  2. Try the SIM card in another phone.

If the SIM card is not working in another phone as well, then you might want to get another SIM card.

Thanks @icantremember for pitching in. I agree - “the phone is locked” doesn’t seem to be the right messaging from Mint team.

@Sharad, It may be an issue with the SIM card. I’ve tried it in both of the SIM slots of the 2e (no mobile data in either, and couldn’t edit/add APNs in either slot) and haven’t used it in any phone except the 2e.

The cell phone I used previously isn’t under contract anymore, so would I need to activate that carrier agreement again and then put the SIM card currently in the Teracube into my old phone?

Alternately, could I ask a friend to let me put this potentially troublesome SIM card into their phone? I don’t know much about SIM cards. Would that have any effects on their phone that they wouldn’t be happy about? losing settings or anything like that?

Thanks for any help.

You don’t have to (and you shouldn’t) activate your old contract for the old phone. There are 2 possibilities:

  1. Your old phone’s carrier contract is over but they still left the phone locked. In this case it won’t work and reactivating contract is waste of money.
  2. If your old phone is unlocked, then it’ll work.

Simply put the SIM into your old phone and see for yourself :slight_smile: .

Nope - putting a SIM card into a friend’s phone is safe and will not remove any of their settings. You’ll need a TMoble compatible phone since Mint runs on TMo.

I don’t think the mint sim would work in the boost phone at all. Boost only sells/sold locked phone that work(ed) on their network (sprint).

Best case would be to try the mint sim in someone’s old unlocked phone, I think.

@Sharad My previous cell phone was locked, I just checked and the SIM is from Sprint, so it seems like @icantremember is correct.

If I put the SIM card from Mint Mobile in a friends phone, I’ll know if it’s working if they are able to get mobile data?

I might know someone with an unlocked Tmobile phone that would let me try my SIM card, but I’ll have to ask around and it will take some time.

Thanks for your help. I’m also trying to figure out how to save my WiFi password to see if connecting to WiFi on restart will let me add an APN.


That whole wifi thing makes no sense, either. I’ve been using Android phones since the original Moto Droid and I’ve never heard of wifi not saving password.

@icantremember it’s 100% possible I deserve some of the blame, I’m good at a fair number of things, but cellphones are one of them. the wifi issue is a pretty low priority for me but mobile data is something I need to use a lot.
Fortunately, after spending basically the entire day trying to get this taken care of, I’ve finally had success.

The SIM card wasn’t the problem, the wifi password wasn’t an issue and to be honest, I’m not even sure what was causing the trouble. But I was able to chat with someone on the Mint Mobile support staff that had a quick, simple solution to my data problems.

In case anyone runs into this issue later, Mint Mobile directs users to this page ( that lists settings to add for APNs. That didn’t work for me and neither did the other solutions their support offered. But these slightly different settings did the trick:
Name: Ultra
Apn: Wholesale
Multimedia messaging port: 8080
mcc: 310
Mnc 240
apn type: default,supl,mms

its the same we just change the 260 for 240. that works like a charm in most devices"
It definitely worked like a charm on mine, frustrating that I had to speak to multiple people before I found my APN savior Gustavo Lezama, but I’m glad I don’t have to worry about this anymore.

Thanks @Sharad for troubleshooting even though it wasn’t a Teracube issue like I assumed it to be at first. Looking forward to putting the Teracube 2e through its paces now.

1 Like

Changing 240 to 260 allowed you to save the apn?!

Consider my mind blown.

I know. If I wasn’t so glad to have the problem solved, I’d be pretty angry no one made that suggestion earlier.