No mobile data with Android 11

I have a Teracube 2e. Since I upgraded from Android 10 to 11.0.4, Internet only works on WiFi.

When I’m not on WiFi, I see the 3G symbol instead of LTE, and my apps say they can’t connect to the Internet. I’m in Montreal QC where LTE is usually excellent.

My primary SIM is from Virgin Plus, which uses the Bell Canada network. I tried several different APN settings, but none of them worked.

I also have a second SIM, but I only used it when I’m in Europe. It’s from o2 Germany, and I disabled roaming with it.

1 Like

Sorry for the trouble.

Have you contacted the Carrier to get the proper APN settings and to verify what Bands your region is using?

Sorry, I should have tried that earlier. I found the correct settings in my carrier’s community forum (

Name: Virgin Plus
Port: 80
MMS proxy:
MMS port: 80
MMS protocol: WAP 2.0
MCC: 302
MNC: 610
APN type: blank

The factory settings for don’t know about the proxy server.

Now it works for me.



I’m glad you’re up and working.