Phone screen not waking

When on a call the screen goes blank (as it should), when you move the phone from your ear to end the call the screen should wake up. My phone is not waking the screen. To disconnect the call, I first need to hit the fingerprint sensor or power button to wake the screen. Then I can disconnect the call. Is this happening for others? Does anyone have a suggestion on how to get the correct wake lock working? I tried with on-body detection on and off, same result.

Is it happening for you all the time or sometimes? When you unlock the phone in these cases, is the phone app on top or is it in the background?

I do have a possible explanation but will wait for your reply first.

It is happening on all calls, except on the speakerphone (of course). The phone app stays focused so it is there as soon as I wake the screen. I am going to switch back to the stock launcher today to see if it is a quirk of the launcher I am using. Bring on your possible explanation :grinning:

My earlier explanation might not be accurate based on your response. Still its at the bottom of this msg.

Could you test a call with phone placed on table (not on speaker) and use hand or paper to test proximity sensor. The screen should switch off when hand/paper is close and it should come back when the hand/paper goes away. Leave the call on and put the paper on top of the earpiece for 1 min+ and then check whether the screen comes back when you remove the paper.

Things that could help investigate further:

  • How much is the distance at which screen goes off? 1-2 inches, more or less?
  • Does the screen come back on after you remove hand/paper after 1min+?
  • Now test the same with the phone on your ear during a short call - being aware of the screen. Move the phone away and check if the screen comes back on. You can repeat moving the phone away and back multiple times.
  • Is there a slight chance that the power button is getting pressed while you are on a call?

My prior thought:

During a call, the screen may not switch off instantly (due to phone-ear distance). In such cases, the screen may get pressed before it switches off and the call may go in the background. Call will continue normally - however the phone will no longer use the proximity sensor to switch off the screen (since the call app is not in foreground). Instead the display will time out as it does regularly and the phone will need to be woken up using fingerprint or power button.

Great, as soon as I get back home and have a few minutes to play around I will give this a try.

Here is what I have found. The proximity sensor seems to work normally until the call connects i.e. I can pull the phone away from my ear while the call is connecting and the screen will wake normally. Once the call has connected there is no reaction from the proximity sensor no matter what. I can put the active call down and try to use my hand, nothing, same with moving it from my ear. The only way to wake the phone is with the power button or fingerprint sensor. I am going to keep playing around and try to see if there is an app, or such, causing the interference.

That is indeed strange. Are you using the default Google phone app or some other app?

Here is a google thread similar to this issue -

It could be a 3rd party app permission issue. This is a suggestion from the above thread:

Does the problem also go away for you while booted into Safe Mode, as Paul reported above? If so then that does indeed indicate an issue with a third-party application you installed on your phone. Google isn’t really able to provide support for third-party applications that cause problems like this, and it can often be a bit difficult to identify the culprit. That’s ultimately something you’ll have to figure out on your own but I’m happy to try to help.

You might be able to narrow down it down a bit by reviewing the apps that have been granted the Phone permission, as listed at Settings > Apps & notifications > Advanced > App permissions > Phone . This can also sometimes be triggered by apps which draw over other apps so check those at Settings > Apps & notifications > Advanced > Special app access > Display over other apps .

You could also try resetting all app preferences and permissions in bulk to see if that makes a difference. Do this at Settings > System > Advanced > Reset options > Reset app preferences .

Well, I still have not found a solution. I am using the stock phone app. I tested the proximity sensor and got 0 when the sensor is covered and 1cm when moving away from it. I ran in safe mode and had the same problem, blank screen until I wake it with the fingerprint sensor of power button. Safe mode should have eliminated interference from apps so I am not sure what to try next.

Agreed - safe mode does eliminate 3rd party app. Could you try the following in sequence:

  1. Clear cache partition
  2. If that doesn’t help, then clear Cache and Storage under Settings > Apps & notifications > Phone > Storage
  3. If 1,2 don’t work then Backup and Reset

These will rule out any software issue. At that point, we can pursue a hardware replacement (although proximity sensor seems to be working)