Phone stopped working after three days

This morning I wanted to check my e-mail on the phone Teracube 2e stopped working. Three days after receiving it.

I rebooted the phone and now I get Chinese texts … Nothing happens.

After watching some Youtube-clips I tried to hard reset the phone. It gives an error: can not format …

The phone is used for my job,

How can I solve this?


Hi @hub - welcome to the Teracube community.

Could you please take out the battery for few mins, re-insert it and try again. Make sure you are only pressing the power button to power on the phone.

1 Like

Thanks for your reply,

I did this, and it worked.

Then I powered off and let the phone be for ten minutes.
Inserted the sim-card and I got the same problems.

Tried it several times, still not working …

I hope I do not have to pull the battery every time for ten minutes. Remember it crased the first time when the phone was powered on.

Can you please give me real support on this, this should not be possible. Is it a buggy device, that for some reason past the quality control or … (I send a support request to the dedicated emailaddress before I posted the issue on the forum …)

Hope to hear from you.


Sounds good. Please follow up with our support team for next steps (you should receive a reply back our Monday morning Pacific time)

Sounds good?

Nope. I had to do several battery pulls with a waiting time of at least 15 minutes before it went working again.

With the bumper the sound buttons not really respond. Today the on/off button stopped working. So I took the bumper off. This button works now, but the volume buttons do not.

And when I want to remove the bumper, the backcover comes off too …

Pfff. I love the concept, but the quality of the product is … sorry … poor.

Refund please!



With the case it might not have been on fully. Same possibility with main back cover.

When I first took off the case I thought it was the back cover. After I clicked the plastic back cover on phone. Removing the case doesn’t pop off the cover that easily.

The issues with Volume and such is quite possibly a qc issue maybe.

No reply at all from support …

Thanks for your reply.

I tested it again, and both parts (bumper and backcover) were correctly mounted. But when I removed the bumper the backcover came with it. Again …

1 Like

Hi @hub - the team is working on your ticket. They need 1-2 days to sort it out.

I was going to say that buttons not aligned properly could be resulting in accidental press of buttons. The Chinese menu you are seeing is the Factory menu that comes when power and volume buttons are pressed together at boot time.

I guess you have already checked button and back cover alignment - so may that is ruled out.

One more thing - there is a small trick to removing the case such that the back cover does not come of with it. You can see it in action in our unboxing video starting at about 0:37.


Dear Sharad,

I do love your project, but this takes far to long.

I am a freelancer and need a phone to earn money. I am not able to communicate with my customers now, so I had te buy a new phone.

Furthermore, I described the problems good enough. And it is silly too keep me waiting while it is more then clear at least this device past the quality control, while it should never has leaved the factory and be recycled.

I really love what you are doing. One of your selling points is TeraCube is not like the other phone suppliers, e.g. you promised to solve problems fast. So, be honest, transparant and admit at least my device is faulty and refund my money.

Have a nice day.