Puretalk Mobile Data will not work on /e/ OS

My cell provider is PureTalk, an AT&T reseller. I cannot get mobile data to work reliably. Sometimes their tech support will get it working, but it eventually stops. Any advice? Do I need to change providers?

Hi @jalbright318 is your teracube 2e is 2021 model or 2022 model? Are you running teracube’s stock rom? And as I think you’re having issues with mobile data, can you try resetting APNs to default?


Changing providers is like playing roulette, and will be costly. Non of these providers have been playing it straight with their customers since the 3G take down. From PureTalks website: Are you using these settings?

If there’s anything else in the settings…delete them.

In addition to suggestions made by @Pat_2284, we recommend that folks move to TMobile-based carriers. Here is the complete list of working carriers.

My teracube 2e is 2022 model. I do not know how to determine whether I am “running teracube’s stock rom” - can you advise? I tried resetting the APNs to default, and then selected Pure Tallk USA. Then restarted my phone. I now have mobile data - slow, though. And based on experience, will stop working after a while.

Thank you for this information. I wish Teracube would let people know before they buy that this phone will not work with all carriers, so we can make an informed decision. I am not sure I would have sprung for this phone had I known, as switching carriers will more than double my monthly cell bill, and I am a retiree on a fixed income.

Thank you for this information. I reset everything accordingly, and now have mobile data. Very slow, and based on prior experience, not likely to “stick.” For other readers, the link to above settings is: Data Issues | APN Settings | PureTalk, since screen snapshot above is difficult to read.

As I noted prior, it appears this is a chronic problem with some carriers and may be only fixed by switching to a T-Mobile network, which will more than double my cell bill… sigh…

Hi @jalbright318 - how much are you paying for Puretalk? There are many affordable TMobile-based carriers.

  1. Tello (tello.com) starts at $5/mo and has 1GB unlimited plans at $10/mo
  2. RedPocket plans start at $10/mo
  3. Mint Mobile is $15/mo with an annual payment
  4. TMobile prepaid starts at $15/mo for a 2 GB plan
1 Like

Thank you so much for this information - I will check them out! Seems like it is the best solution.
Thanks again!

Sounds good. If you go with RedPocket, ask for their “GSMT” SIM (TMobile based).

Well, I am back. I tried Tello and then T-Mobile, but mobile data didn’t work any better than it did with my lower cost carrier, PureTalk. Which was - I was able to use mobile data, but it was very slow and worked for only about 10 minutes at a time. Then would freeze. I would then have to restart the phone. I think I have concluded that this is the cost of having a de-googled phone, and it is a price I am willing to pay, now that I know. Just wish I had known up front so I would not have wasted so much time trying to get it to function like a “regular” smart phone.
So I have switched back to PureTalk but now cannot access mobile data at all again. The required APN settings will not “Save.” I’ve tried numerous times, and just went through a total reset process with PureTalk technical support, all to the same end. After inputting all the settings for a new APN, click Save, and they don’t. This is a new problem. Any suggestions?

Have you updated to the latest current version (Android 11.0.4) or are you on a prior version still? In general, 11.0.4 works great but if you’ve actually gone de-Googled, then the question would be whether you’re on the latest version of /e or whatever flavor you’re trying?

Hi - thank you for your reply. I am using a de-googled phone, teracube 2e, hence why I am posting to this community. software was up to date at the time I installed the SIM card. Now cannot connect to the Internet at all - neither mobile data nor WiFi will work. the phone will not save the required APN settings.

Hi @jalbright318 - I’m guessing you are running /e/ OS. It might be a good idea to post this query in the /e/ forums as well.

I had a problem getting my APN settings to save also (with a different carrier). What eventually got it to save was to leave MCC/MNC on their default values when adding the new access point. I hope this is helpful.


Oh my goodness - that worked! Thank you so much!

1 Like