Recovery boot loop. Possibly full storage? Can't create log files


My wife’s phone is stuck in a recovery loop. When it boots, it complains about not being able to create a log file, a load of apps complain and crash, then the phone reboots into recovery. I suspect that the storage is full and that’s why the log files can’t be created. Before this started she had just recorded a video and was trying to send it to someone.

I have tried using adb to find and delete some files but I can’t seem to find any user data.

Pretty sure the phone is the 2nd batch (adb shell says “emerald”).

Can someone please help me free up some space or at least get the photos and videos off before resorting to wiping the entire thing. Seems a bit harsh that running out of storage space nukes all your data.


1 Like

If you can access adb shell, you should be able to use rm (with optional recursive force -rf) to clear off enough space to get back to functional. If needed, you could adb pull files off to get them to safety beforehand, but the contents of the download folder might be a safe target for a quick purge after verifying.

1 Like

Thanks for the reply. I’m having a hard time locating any files to delete. Where are the user files? Most folders are empty.

1 Like


Sorry for the trouble!

Is the device stable in ADB/Fastboot, meaning you can use it without reboot issues?

Yes. It is stable.

If you’re in adb shell, you can ls your way through. I’d start by looking for:

Those are my equivalents in Android 11, but if none of those work, you can wander with your adb shell.

1 Like

None of those locations contain anything. I’ve wandered all over the place and can’t find any thing.

1 Like

Do you know of any particular file name you have on there? A saved file or downloaded file?

You might be able to use find *.extension to see where it may be.

find / -type f -name "*.jpg"
find / -type f -name "*.jpeg"
zero results

This can’t be right. When the phone boots, the lock screen image is visible which is a photo. It’s not as if the files have disappeared. It’s definitely there somewhere.

It’s finding these but surely there are more png files than this.

1 Like

Solved it.

Turns out there’s a safe mode.

Booted into safe mode. None of the apps try to load and fill up the last of the storage with logs. Deleted some files. All good.


Just adding to this - I’ll also suggest using an app like “Files” to uninstall most unused apps.