SIM 1 not allowed

When out and about, I often get the SIM 1 not allowed message, and it seems I have to go to airplane mode for 30 seconds, then click out of airplane mode, to get it to re-connect to the network. I have T-Mobile. It’s a T-Mobile Sim. (Originally Sprint but they had us go in and get T-Mobile SIMs)

Any ideas to have it re-try connections without airplane mode?

Can you test the SIM card on SIM slot #2? Also - could you report the build number that you are running (Settings > About phone > Build).

Haven’t seen reports of this issue so far. So if the SIM slot #2 does not fix it, then we can take a look at your logs.

My sim card is too small for slot sim 2. Do they make bigger cards? My build is QP1A.190711.020