Sms not sending over wifi

So I’m using a Straighttalk sim card (from my previous phone) and I can’t send or receive sms. I’ve already turned on wifi calling, and I’m using Textra as my messaging app. Even with the Messages app that came with my phone, it doesn’t work. Please let me know what I can do to fix this. I tried renaming the aim to Straighttalk, as it was named Verizon before.

also, when I try to add or edit an APN, it doesn’t save. If I try to add a new APN, it doesn’t save at all, and if I try to edit an existing one, it doesn’t change the settings. tried restarting and tried setting apn with and without wifi on. ugh

Is your Straighttalk running over Verizon? If not, what underlying carrier is your SIM using (their customer service might be able to tell you).

This could be forced by the carrier. Were you able to do this on your previous phone?

okay so I activated and installed my new SIM card which is t-mobile compatible under straight talk, but I am still having issues with sending and receiving text and calls. now, the texts are saying that thy are sent (before they weren’t sending) but when I asked my Mum via email, she said she still wasn’t receiving my messages. I tried to edit the APN settings but just like before, when I tried to save the settings, instead of saving, it actually deleted that apn entry entirely. Not sure what’s going on. Please let me know what to do next to try to fix this. thanks

ps: moved your post to the relevant thread.

Could you use a screen recording app (example) to capture your APN experience. Please share the video directly as a PM to me (by clicking on my profile) or by emailing

yes, just emailed it

Got your email. It is indeed bizarre that the APN is not showing up after saving. I’m assuming you have rebooted after saving. There is a chance that our Straight Talk APN settings on the forums are outdated.

  1. Do you happen to have another Android phone to check this with?
  2. Can you call their customer service to get updated APN settings.

my other phone doesn’t seem to give me APN settings at all and yeah, I’m going to see if I can contact them for an updated APN settings. I’ll keep you posted.