SMS over wifi with 2e

Hello all, I live in a rural area and out of range of a cell tower (there’s one in town but the signal falls short of reaching my house)

With my previous phone I was sending and receiving sms and mms messages via my wifi and didn’t think much of it. Though now with the 2e I can’t seem to get it to work. I’m curious if anyone else has any experience or thoughts regarding this? With so many products and accounts using sms for 2fa this is pretty important to get resolved.

FWIW: I’m on google fi and the best I could come up with was this here, not sure if it’s what I’m looking for.
https://support.google.com/fi/answer/7189714?hl=en

Hi @Brian_Taylor - few questions:

  1. Is your Wifi calling enabled? If yes, is it set to be prioritized over WLAN? These settings are under Network & Internet > Mobile network > Wi-Fi calling.

  2. Are your calls going over Wifi?

  3. Have you enabled Chat settings in the Messages app as mentioned in the article you references? These settings are under Messages > Settings > Chat features.

1 Like

I have wifi calling enabled, and am not able to make calls over wifi either. As for enabling chat settings in the messages app, I get to the screen and it says that Chat features is not available for my device

This could be due to Google Fi needing something special for its Wifi calling. This is one of the reasons we do not have Google Fi as a supported carrier. Is it possible for you to test with a TMobile SIM?

Hi Sharad, it took some wheeling and dealing, but I got my hands on a t-mobile SIM. Is there some kind of trouble shooting that I can do now that I have it?

Also in my exploring and searching for an answer I looked at Settings>Network & Internet>SIM cards: and noticed a few things. 1) it was calling my Google Fi sim card a T-mobile sim card until I renamed it (curious) and 2) when I turn on airplane mode the slider next to SIM slot 1 gets turned off. (Perhaps this is to be expected)

With my old phone, since I know I’m well out of range of a cell tower, I’d have airplane mode enabled to conserve battery life, and was still able to text and call over wifi. However, with the 2e when I go to make a phone call I get an error saying I need to deactivate airplane mode before making a call. This is in spite of having all wifi calling options enabled whether in the Fi app or the phone settings. Even with airplane mode off, calls fail and I get an error that the mobile network is unavailable.

Another thing to note (I’m sorry if this is too detailed and not useful) I normally use Signal as my default messaging app, after setting my default as signal (I had to go to town to get the SMS confirmation code), I am now able to send and receive SMS messages over wifi, even if I switch my default messaging app back to the stock messenger app, even with airplane mode enabled! Signal has an option in their settings menu labeled “‘Wifi Calling’ Compatibility mode” after enabling this my SMS began to work (Haven’t tried MMS, there is still a considerable delay before messages arrive but it’s workable mostly)

So at this point I guess the reality of my issue is that Wifi calling doesn’t work when airplane mode is turned on, nor when airplane mode is off.

Let me know if somehow this T-mobile SIM can help troubleshoot.

TMobile’s WiFi calling is working with Airplane mode - I am able to call and send SMS both.

Here are the steps:

  1. You need to enable it under Network & internet > Mobile network > Advanced > Wi-Fi calling.
    1.1 [Important] set the Calling preference to “Call over Wi-Fi” if you want to prefer Wifi over Cellular.
  2. Once this is set, make sure the “Vowifi” icon is there (visible once you pull down from the top).
  3. Now you can enable airplane mode and enable WiFi. The Vowifi icon will also make it way back in few seconds.
  4. Test calling and SMS.

Hi Sharad, it’s a semi long story but suffice it to say in the end I wasn’t able to get a T-mobile SIM :confused:

Looking through my phone’s settings I don’t have one for ‘calling preference’ that I can set to call over wifi. I’m guessing this is because maybe the settings options change a bit from carrier to carrier? I also don’t see any VOWifi icon

If I had been able to get a Tmo SIM and it worked, would your advice to me essentially have been to switch to Tmobile? Because unfortunately that’s not an option for me. I’m going to reach out to Google Fi and see if there’s any way I can get this sorted, but if not I might have to pass my Teracube on to someone else.

If I give the Teracube to say, my mom, or my sister, does the warranty transfer?

Yes - we would recommend moving to TMobile. Google Fi does some custom stuff that may or may not work with our software. Especially working only over Wifi.

Yes - of course. The warranty is fully transferable.

1 Like

Ah, ok. Unfortunately switching carriers isn’t an option for me, so I guess I’ll have to start looking for a new phone.

I do like the Teracube and it’s great as a palm computer, I just wish it worked as a phone for me. Thanks for your help in all this and good luck with the project. If you guys make a software update that improves Fi compatibility I’ll be happy to back your next phone.

1 Like