[SOLVED] Is USB-C cable shipped w/ Teracube 2e a data or power only cable?


I’m trying to migrate into my new teracube 2e, bought with /e/OS preinstalled from Murena.

I’d like to copy data in and out of the phone via the USB cable.

When I plug the cable shipped with the phone into a USB-A slot on my computer, no notification is displayed indicating a choice of charging or data transfer. Additionally, there is no listing for the phone in the output of the lsusb command on my computer.

Is the USB-C to USB-A cable supplied with the teracube 2e a data cable? Or for charging only?

Thank you…

John A

I’ve tried 3 different cables now, with the same result: no notification allowing change from charge only to data transfer.

It seems it’s not the cable, but the phone or /e/OS.

When I plug a USB-C cable into the teracube 2e it is difficult to insert, and often has to be wiggled around before even the charging is initiated.

Maybe the connector in the phone is bad?

I think a better subject would be: Can data be transferred over the cable included w/ the Teracube 2e?

I’d like to change the subject to better represent the question, but that doesn’t seem to be possible…

John A

Hi @johnea - welcome to Teracube forums. Yes - the included cable is a data cable as well. Could you try plugging into a Windows computer to see if that makes a difference.

1 Like

Hi Sharad, Thank you for your reply!

I found my trouble. When plugging the USB-C cable into the teracube, it really didn’t want to plug in, I had to push in from an angle. Then once in, I still had to wiggle the cable around even before charging would be indicated.

I guess, I just wasn’t pushing hard enough 8-/ On one re-insertion of the cable, I pushed it harder, and it seemed to snap into position.

After this the USB modes notification was present on the phone, and the phone was present in the lsusb command on the computer.

After enabling developer options, and android debug access, I’m able to adb shell into the phone, and transfer files!

Thanks again for your support on the forums!

John A

p.s. I also found the edit button for the post subject, and will mark this post as SOLVED

1 Like