Speakerphone for incoming calls

I cannot figure out how to turn on speakerphone during an incoming call. I see the speaker icon when I make a call, but not when I receive. Anyone know how to do this?

You can put the call on speaker after answering the call (there is no way to answer directly on the speakerphone). I just answered a test call from Amazon alexa :slight_smile:. If you can’t find the speakerphone after answering the call - could you take a screenshot and post here (power button press/hold > screenshot option).

All set, I just called myself from Alexa also and I see the speakerphone icon.

I had gotten a call from an automated call number (like from a bank or hospital) and there wasn’t a speakerphone icon available. I’ll try to take a screenshot if it happens again.

I’m happy with my phone so far, downloaded the update, everything seems fine. My only suggestion would be to make the little tray for SIM and micro SD cards a bit better, the cards like to slide out of place when inserting back into the phone.