T2e 11.0.4 - texts issue on Public Mobile (Canada)

Since updating to 11.0.4 about a week ago, I no longer receive texts unless I have recently† sent an outgoing text. Outgoing calls and use of mobile data aren’t enough: it has to be a text.

(I’m on Public Mobile, a Telus subsidiary. I use QKSMS as my interface app.)

†Within the last 24 hours? Yesterday my last outgoing text was 4:22 PM, and today I received a text sent at 3:58 PM but not one sent around 5:30.

Hi @Beckyway - this is most likely an APN issue. Could you tell us which build you upgraded from? Android 10 or 11.0.x?

It was 11.0.2.

Thank you. And were the texts working on Android 10 (before 11.0.2)?

Yes, at least with QKSMS. I did have trouble with dropped SMS messages a while back when experimenting with using Signal as an SMS interface, but that stopped when I stopped using Signal.

1 Like

We will take a look and get back soon.

Quick question - have you added QKSMS to Duraspeed so that it’s allowed to run in the background?

Huh. I thought I had Duraspeed turned off, but it seems to be on again.

I turned off Duraspeed again. My last outgoing text was 8:41 PM: I’ll skip today’s keepalive text and see if I can still receive texts tonight.

Hello you could try this apn setting as I use public mobile also and the texting is fine here with this apn.
first page Apn = sp.mb.com The mb would switch to your province I believe. Please find in the attach photos a copy of my current apn for public mobile in mb canada

Also, on Android 10, Duraspeed was broken in that disabling it only turned off your ability to control it, it didn’t stop it from blocking background processes. The way to disable Duraspeed in Android 10 was to turn on background access for all apps, then disable it so you felt better about the screen. :smiley: But yeah, if you aren’t wanting to enable specific background apps, I’d definitely briefly enable it, turn on all, disable again.

Hi @Beckyway - could you please try a few things:

  1. Can you try the default Messages app to see if the issue happens there as well?
  2. Just to confirm once again - do you get all your pending texts once you send a text or are some texts never received?
  3. Switch to 3G (Settings > Network & internet > Mobile network > Preferred network type) and see if the issue persists.
  4. Share logs with us (howto).

Just a quick update to let you all know that I had to send some texts over the weekend, so it’ll be at least another few hours before I’m able to start trying your suggestions. When I get the chance, I will test things one by one and let you know what I find.

@Sharad, missing texts are never received.

1 Like

I sent myself a text from another phone 28.5 hours after my last outgoing text, having turned off Duraspeed on Saturday as mentioned earlier. It worked.

I’ll continue pinging my phone occasionally for a few days and see if it keeps working, but so far it seems like Duraspeed was the issue. (Although there’s also the possibility that Public Mobile happened to fix something on their end.)

1 Like