Teracube 2e has suddenly stopped working

My Teracube 2e has suddenly gone blank. I can hear it, but the screen does not light up. This has happened completely out of the blue after charging it - there were no issues with it; it hasn’t been in contact with water or dirt.

I’ve tried long-pressing all the buttons. I’ve taken the battery out and replaced it. I’ve tried putting it on a different charger lead. I’m not sure what else I can do. Does anyone have any other ideas? I’ve had the phone for almost 8 months, with no major issues.

1 Like

Sorry to hear this!

Does USB transfer work at all? It may not if the screen is not registering clicks.

You might be able to hear if it is registering clicks if you have the volume up and tap around.

It sounds like perhaps the display panel died.

1 Like

Thanks for shedding some light on this Saijin.

I’ve never managed to get USB transfer to work with this phone, but I am able to access data from the phone via internet connection. I will put the SIM into another phone and will contact the manufacturer after the Easter weekend.

1 Like