Teracube 2e NFC - Google Pay and Freestyle Libre issue?

Just bought a 2e a couple of days ago. Spent a good many hours getting apps installed and set up again. Everything works fine and perfectly happy with the speed and responsiveness (moving from a Moto G5S which was still working great for me but the battery died after over 4 years).
The only thing not working is the Librelink app as you say. I manage to get a read 1 in 10 and most of the time I either get scan error, or it asks me which app I want to use. The sensor still reads perfectly with a reader and my old phone.
I just tried making a Google Pay payment and that wouldn’t work either. It’s almost as if there is a hardware problem with the NFC antenna having very low sensitivity. Anyone else have this problem?

1 Like

Hi @chuzzlewit - welcome to Teracube forums. Unfortunately Librelink is a known issue. However, Google Pay should work. My quick NFC tag testing is working from almost a cm distance (which seems ample/secure). Is your Google Pay setup complete?

ps: I moved your post here to separate the discussion for Google Pay.

1 Like

Google Pay is now working - it was just the first retailer I tried that failed, so looks like a one off. Unfortunately, I’ve had to request a refund for the phone as using it to scan my Libre 2 sensor is a major part of how I use the phone.
It’s a shame, because everything else about the phone offering was spot on for me. Fix the Librelink issue and you will have yourself another sale!
My Moto G5S and G8 Plus both read it perfectly, and they are also supposedly stock Android. G5S is 8.1 and G8 is (I think) v10.