Teracube wants me to send them my phone but I cannot factory reset it

Hey all,

The title pretty much says it all, my phone started acting weird (mostly minor screen glitches) then one day just turned off and would not turn back on. They sent me a factory referb replacement (with a $100 deposit) and now they want to me to send my old phone to them to get the deposit back.

I feel a little bit uneasy about sending my data off into the ether, does anyone have any experience here?

1 Like

If you want to completely wipe your data, you could do a stock OS flash as documented here.
This should wipe userdata as well, hence erasing your doubts as well.
This solution is suggested since the device according to the OP will not power on in any scenario.

Feel free to ask for anything on the forums.

1 Like

Hi @Terasphere - you can wipe your data completely using factory reset (instructions). Be assured no one can access your old data once you do a reset.

Also, as an additional step, we do a reset for all phones once they come in.


Thanks for the replies, I tried following the steps for flashing the phone, but my computer does not recognize the phone as a USB device (when it was working it did).

The flash turns on when it’s plugged in, I’m not sure if that means anything.

Does it begin flashing? If that’s going on your data will be wiped fine…
SP Flash Tool can flash even without a battery, afaik
As long as it can get a serial connection

It does not begin flashing, it sits there with no movement on any of the indicators.

When I plug in the phone I get this error message (image below).

Can you install these drivers, reboot your computer, and try again.

If it still doesn’t work, then remove your battery and connect USB while the battery is out of the phone (flashing works without battery).

1 Like

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.