Trouble with Backup to Google Drive

So I turned on the Backup to Google Drive feature and clicked back up now. The problem I’m having is the Teracube backup, google photos and contacts all says “Waiting to backup…” It has been like that for a while so I turned off the backup to google option but if I turn it on again those 3 are still waiting to backup. I checked the support articles and it says check with your device manufacturer.

There is a known issue in Android 9/10 where some users experience this behavior. Here is one article (with partial solution) -

Could you try the following:

  1. Goto Settings > Security
  2. Disable PIN/pattern security (temporarily)
  3. Try enabling the Backup now.
  4. Re-enable security.

Let us know what you find.

It worked with the phone backup but photos and contacts still says “Waiting to backup…” should I turn off Backup to Google Drive for now? I’m afraid it will drain the battery much faster.

Battery should not be a concern - you will know within few hours. Have you tried rebooting to see if photos and contacts work after that?

If reboot does not work, you could try ADB commands mentioned in this article.

How to get ADB working tutorial on XDA

yes it worked with contacts but now its waiting to back up again. Do I need to disable security again? Is there a way to do this without disabling security everytime this happen?

If disabling and re-enabling security does not fix it for you permanently, then you can also try :

  1. Clear cache partition
  2. If you have atleast one backup, then do a Factory Reset

ok finished doing those steps but with security on it’s still stuck on waiting to backup. it seems a lot of android phones have this issue as well.

Sorry to hear that you are having problem with the Google back up. I have definitely experienced a fair share of this on my other Android phones. I know in the past, one of the way to resolve the problem is to remove the Google account on your phone, reboot the phone and then add the account back on. Sometimes this may fix the issue.

tried it but it’s still stuck on waiting to backup.

Has the backup ever worked for you? If so, can you delete the previous backup and try again? If that doesn’t work or there is no previous backup, try this:

  1. Go to Settings, then Apps & Notifications.
  2. Select > See all xx apps (xx is the number of apps you may have installed so it varies for everyone).
  3. Looked for Google Play Services (not Google Play Store). Click on Storage.
  4. First, select Cleared Cache and then Cleared Storage follow by Clear All Data. Click OK on the prompt to proceed.
  5. Once completed, reboot your phone and run the backup again (make sure using WiFi to save cell phone data).

sorry for the late reply. yes the backup worked for me before since the photos were copied to teracube. i tried the steps you suggested but it’s still waiting to backup. any chance a patch or perhaps an upgrade to android 10 will fix this issue?

it seems this problem has been around for a while

Is it correct to say that backup worked for you before the software update but not after? I am trying to pinpoint when it stop working and the cause so I can further assist.

In addition to what @anthony asked, I’m also curious as to what your Google photos app shows? Usually there is a cloud with a tick towards top-right. Other way to check is Google photos > settings > Back up & sync.

While I was typing this, I thought of 1 more thing. Are all your apps (especially play store infrastructure) updated? Check in Play Store > My apps & games.

That’s a good point. Google photos backup is not part of the Google account settings (see below).

So in terms of Google Photos not backing up, it could be because your Google account is full. If you choose the High quality (free unlimited storage) allows you to upload photos with no cap in storage limit. Otherwise, the Original option would only provide you with 15 GB of storage.

I was able to use backup whenever I disable the security options on the phone as for google photos it says 2% full. Sorry for the late replies there’s just a lot going on here these days.