2e won't connect to wifi with hidden SSID

My first ‘smart’ phone! Thus new to Android too.

The 2e will only connect to wifi if I unhide the SSID, this has never happened with any other device, different hardware, different OSs(including Android), it made no difference but only the 2e has failed to connect. Nearest problem I can find by Googling was an FP3 which had same problem…resolved by “…enable the “Advanced settings” and set “Hidden network” to “Yes”” but the e2 doesn’t have that option for the wifi setting.

Not a good start…it can only get better?

You can connect to a hidden Wifi network on Teracube 2e. Here are the steps:

  1. Goto Wifi settings
  2. Scroll down and tap “+ Add network”
  3. Enter all your networks settings like SSID, security, etc.
  4. In Advanced Options, enable “Hidden network” to Yes.

Thanks Sharad!! I was actually not scrolling down far enough to see that option and totally forgot that was located down there on these newer versions of Android. I got it connected up now and it’s working good :smile: