[ Advanced ] Rooting Teracube One

My issue was just not having it plugged into the correct USB port. I remember having issues with adb/fastboot in the old days where sometimes it is just finicky about which USB port the phone is plugged into

This worked flawlessly for me on Linux. I had to run fastboot as root of course.

I am wondering if anybody has managed to Flash the Stock Android Image and Unroot the device?
Are there instructions for that as well?

Thank you

If you are referring to Android Generic System Image (GSI), then yes it does work. Infact I just made the GSI instructions public which had been sitting in draft mode.


I assume these instructions don’t work for the 2e, will they be updated?


Yeah - we will need a different boot.img (and slightly different instructions maybe). We have yet to do a root for 2e - stay tuned.


A post was split to a new topic: [Advanced users only] Teracube 2e root

Do these instructions still hold true following Magisk consolidation of Magisk and Magisk Manager apps?

I ask because certain apps stopped working recently, specifically Disney+ keeps complaining about an update, but Play Store won’t let me update it. I was successfully rooted at some point, but the SafetyNet check in the new consolidated Magisk app fails.

When restarting my Teracube 1 it shows that it’s still in Orange/unlocked state. Do I just re-lock the bootloader and then SafetyNet will pass and hopefully apps start updating again?


Yes locking the bootloader will work (basically goes back to factory mode). Reminder - it’ll cause a factory reset.

So unlock bootloader. Flash rom, have root. But then I have to re-lock the bootloader which basically puts me back at factory mode? AKA no root?

So I have to re-flash this every time a change like this is required?

Your other option is to update from 3rd party stores like apkmirror or apkpure (caveat: such upgrades are not security audited by Google)

That does help with the google play store issue, however it doesn’t help with the BAT rewards I’m unable to claim from using the Brave browser (SafetyNet has to pass)

Newest Magisk seems very different than old Magisk Manager, and I see the images you all have included above are for 20.03/20.04, so I’m thinking step 1 is downgrading back to Magisk 20.04 to see if I can use Magisk Hide to pass SafetyNet (that menu seems to be gone entirely in the new Magisk 22.1)…

If that fails then I guess I bite the bullet, lose the rewards and factory reset the phone, there’s only 1 thing I was using root for anyways (Titanium), but now that Google backup is much improved, I probably won’t even miss that…



Hi all! Any tips on how to get out of a boot loop? I had previously rooted my phone and then after updating to Android 10 I lost root. Tried flashing the boot.img and now stuck in a boot loop.

After unlocking my bootloader using the instructions from the original post, I now have trouble flashing the prepared stock BOOT.IMG which contains Magisk 20.4. Every time I try to fastboot flash boot the BOOT.IMG with Magisk 20.4 on it and reboot, it sends me into a boot loop forcing me to reflash the factory Android image came with my Teracube One.

Is there any way for me to fix this issue?

Are you using Android9-SW7 as your OS or do you have Android 10? It’s been a while since we posted these instructions but I’m pretty sure that the modified boot.img works with SW7.

I was trying to root my phone on Android Red Velvet Cake or in other words, I was rooting my Teracube One on Android 11 with stock OS by flashing the BOOT.IMG containing Magisk 20.4 and it sent me into a bootloop twice in a row before. I don’t know what to do.

I don’t think we have tried rooting Android 11 yet.

@Sharad Sorry about that. I was actually trying to root my phone on Android 10 when I ran into this bootlooping issue.

Same issue - the rooting instructions and boot.img work for Android 9-SW7.

Will there be an updated guide for Android 10 and further on the Teracube One?

1 Like