[Advanced users only] Install Android 10 Generic System Image (GSI)

To add to what you mentioned, there are some telegram groups exploring IMS (VoLTE) on Mtk GSI as well.

1 Like

phh’s latest Android 11 GSIs support VoLTE on Mediatek. Can some brave souls try them out :wink: ?


I tried flashing both the latest lineageos GSI (based on lineageos 18.1) and phhusson GSI image (based on roar) and I’m stuck in a bootloop. Going back to lineageos 17.1 GSI boots fine. Has anyone else tried and gotten it to work? I’m just going back to the previous version, for now.

Seems to work well enough, but I can’t confirm VoLTE

Can you share your steps to flash, and what GSI you used? Maybe I did something stupid :face_with_monocle:

phh GSI 11, latest release.

fastboot flash system system-roar-arm64-ab-gapps.img

Reset cache and data, and it boots in just fine for me.


Interesting, I did the same thing, but with the FLOSS version (for anyone else, https://github.com/phhusson/treble_experimentations/releases/tag/v300.j , system-roar-arm64-ab-floss.img.xz . I reset the cache and data (and system between flashes) multiple times, and every time got stuck in a bootloop :cold_sweat: I’ll let someone else try before wiping my system again lol

EDIT: Because I can’t help but tinker with stuff, I reverted the phone to stock android then flashed the floss image I linked above, and it worked. Something must’ve gotten corrupted somehow before, no idea what, but at least it worked after a hard reset! Thanks to teracube for providing the details on reverting to stock android also!!


You guys using Google Backup for backup and restore between flashes? Or an app like Titanium Backup? Looking for a time-efficient method regarding this. :stuck_out_tongue:

1 Like

SeedVault just started getting integrated into lineageos and the latest FLOSS release I linked to above: https://calyxinstitute.org/projects/seedvault-encrypted-backup-for-android

However, it’s still unclear the exact flow of backup / restore, but it’s probably the best option going forward!


@Sharad, something to consider in the OEM TeraCube ROM for Android 11+?

We could look into it. Google may have issues with it though.

1 Like

Thanks! While that’s a great-looking tool, I’m looking for something to back up my data before I flash LineageOS. Thanks for the suggestion though!

On another note, while this is an advanced user topic, I’m looking for a basic process to go from stock teracube android to LineageOS. Specifically, the backing up of data part. I read online that the /sdcard doesn’t get wiped on ROM flash. Is that true?

Finally, which package of gapps is included? In the past, I’d simply use the pico package, IIRC, but what does this LOS11 image include?

Thanks in advance! Happy new year! :blush:

I didn’t look into backing up going from stock -> lineageos the first time, I had just accepted that I was going to reinstall some apps. I would assume most apps that are available on the play store that backup apps and data would work though, just reinstall the app after flashing the new rom?

I’m not sure why you want to flash the lineageos gsi then put gapps on there, part of the appeal (at least to me) about lineageos is that the gapps aren’t included in the rom. That said, take a look at https://wiki.lineageos.org/gapps.html . There’s also microG , which is included in the FLOSS PHH rom I linked to above, that emulates the google services without including them in the device. Just another route you can go :slight_smile:

1 Like

Thanks for the info!

I actually like Lineage as an OS over the stock Android since it has those nice little features that make it a fantastic daily driver.

I tried microg with lineage years ago, but the issue I had was gps (was pretty wonky), and also the fact that half the apps I use need Google Services (the other half is from Fdroid). Great suggestions regardless! :ok_hand:

1 Like

Just a general warning to everyone - at least on the latest FLOSS phhusson release I mentioned above, text messaging (both SMS and MMS) were very flaky - I’d receive some messages, and miss others. APN settings were all correct, and no base-level debugging seemed to come up with any good answer. I ended up reverting back off the image because I needed more reliability in my messaging. Be warned :ghost:


I installed the latest FLOSS android 11 gsi last night and so far everything is working well.


for the love of all that is good and kind can someone make a guide to flash lineage os on a teracube2e?

I don’t think Lineage is yet available for Teracube 2e. We are working on it though.


I was able to flash Lineage 17.1 and 18.1. 18.1 seems not to have Google Certification to play nicely with MicroG at the time and gave up for different OS.

I’m hoping to flash Lineage/MicroG on a Teracube One. Based on y’all’s experiences, any best practices or warnings on the current state of the art?