[Advanced Users Only][Teracube 2e 2nd Batch (SN: 2021)] LineageOS 18.1 Beta [emerald]

Can someone make a step by step video on how to install Lineage OS onto the Teracube 2e please?

Hi @bluephone - do you have the 2022 (2nd) batch or the 2021 (1st) batch? If you bought it in 2022 then most likely its the 2nd batch. In that case, you can follow Steps 1-6 of the Installation instructions posted in the top post.

I just prefer to watch a video of it being done because then I can know what the process looks like live in person every step of the way.

1 Like

This is exactly where I have been stuck as well. No matter whether I am using the Flash Tool or fastboot with either the stock image or LineageOS, I cannot get beyond that ‘rescue’ screen that you show. The errors at the bottom are also the same (the ‘max minors’ error I showed earlier had to do with the external SD card still being in the slot).

I have researched on other forums and AOSP repo and fiddled with all the settings I could find that did not look like they would further render the phone useless, and now I am out of ideas.

Someone please help us?

Hey @mick @RobertS you can see on your screen, it is on a different slot. Can you please run fastboot --set-active=a and let me know what happens?
AFAIK, SPFT flashes to only one slot (?) I might be wrong, but let’s look at this

1 Like


$ ./fastboot --set-active=a
Setting current slot to 'a'                        OKAY [  0.012s]
Finished. Total time: 0.015s

$ ./fastboot reboot
Rebooting                                          OKAY [  0.003s]
Finished. Total time: 0.053s

Boots the phone to fastboot mode, which is at least a change from the previous screen :slightly_smiling_face:

Should I, after switching to ‘a’ reflash again? I wasn’t sure from your response.

EDIT: Yes!! After running through the fastboot flash of the individual lineageOS .img files again and rebooting it works! Thank you thank you! :partying_face:

1 Like

@Gagan @mick I am happy to report that the change to slot A worked! THANK YOU!!!
This is what I did:

From the recovery screen I selected to enter fastboot mode. Then I ran the following script as sudo:

fastboot --set-active=a
fastboot flash boot boot.img
fastboot flash dtbo dtbo.img
fastboot flash vbmeta vbmeta.img
fastboot flash vbmeta_system vbmeta_system.img
fastboot flash vbmeta_vendor vbmeta_vendor.img
fastboot flash super super.img
fastboot -w
fastboot reboot

I used the fastboot commands as I am more comfortable with them that the SPFT. Perhaps SPFT works with Windows and perhaps not so with Linux.  I don't have any Windows except the kind you see through!
mick, I hope this helps!!

Glad to know it worked.

Does live display work for anyone else? I can’t get it to change to night mode.

The 2021-thread mentions to use fastboot --disable-verity --disable-verification flash vbmeta vbmeta-2e-stock.img to disable image verification - is that still needed?

the command fastboot -w gives:

mke2fs 1.46.5 (30-Dec-2021)
/tmp/TemporaryFile-6hyJ5a: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
fastboot: error: Cannot generate image for userdata

the system boots anyway… :wink:

That is not required on both units as of now. Both LineageOS images flash disabled vbmeta by default, hence reducing the amount of steps users have to jump through to flash builds.

how about the other error?

So after some days using the phone i must say: i am amazed. Most stuff works like a charme! And its a great hardware too (sure i would like to learn more about the efforts teracube undertakes to achieve its goals). These are the remaining problems i currently have:

So all in all: i am happy :slight_smile:

Can you tell if and when a new relaese will be available?

Thank you for the work you put into LineageOS and the hardware!

1 Like

Thank you for your suggestions, and we’ll be looking at improving all the issues you’ve mentioned.
We have an internal beta for March releases already up on the Beta Testers group and I hope I could release it before March end, or April first week.

Looks like an environment issue, but I’ll have a look.

It seems really to be a problem of dust near the sensor. keeping it and the gap to the cover clean solved this issue (for now, lets see :wink: ).


March builds are out!

Get them here!

This link contains SP-Flash and recovery OTA ZIPs.

There seems to be something wrong with your link… i can’t use it. :frowning:

I cannot use the link either, but here is the github release page:

Error on my side. My apologies.
Link’s been fixed. Please let me know if any more issues persist.
Happy flashing!