[Advanced Users Only][Teracube 2e 2nd Batch (SN: 2021)] LineageOS 18.1 Beta [emerald]

NOTE: These builds ONLY WORK for the Teracube 2e 2nd batch (SN: 2021), and not 1st batch (SN:2020). Please read the differences here carefully and flash accordingly.

If you are looking for Lineage for SN:2020 T2e, then click here.

image

LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

What works?

  • Almost everything

What does not work?

  • Double tap to wake
  • FM Radio
  • Serial console notification exists, will be fixed

Installation notes

  • Please UNLOCK your bootloader before continuing. In case it isn’t unlocked, your device will not boot. (link)
  • Builds are SP Flash Tool compatible only.
  • Please flash these builds on devices that were shipped in 2022. Read upper note for help.
  • Ensure you are on stock Android 11 SW5 before flashing these builds.

Installation instructions

  1. Unlock bootloader.

  2. Download SP Flash Tool from here.

  3. Download the LineageOS build here.

  4. Extract SP Flash Tool, and the build.

  5. Load SP Flash Tool, and select the scatter file that is present in the build.

  6. Ensure the option is set to Download Only, and press Download.

  • Make sure your phone is powered off. Plug in the phone, then wait. SP Flash will display a series of progress bars as the image is flashed to your phone. When the process is complete, a small window with a checkmark will appear to let you know the process was successful.
  • You have successfully flashed LineageOS on your device.

Contributors
Gagan Malvi , ​Kshitij Gupta ​​​

Version Information
Status: Beta
Source Code: ​Kernel sources. ​​​
ROM OS Version: Android 11
ROM Kernel: Linux 4.19
ROM Firmware Required: SW5 A11
Based On: AOSP

1 Like

So far, I’ve been using Lineage for almost a day now and have had a couple random reboots, but it was probably something I did. SP Flash Tool is definitely the way to go. Thanks guys for all your hard work!

2 Likes

Thank you!

Also, fyi - I’ve been notified of an issue regarding random reboots while browsing something new.
For a workaround - download this boot image

Please flash this via fastboot -
fastboot flash boot boot.img
and reboot
fastboot reboot

The issues should be fixed; it will be addressed in the next update.

I recently bought a 2022-batch Teracube 2e and followed Gagan’s directions above to flash Lineage OS to it. I’m using a machine running Fedora 35 (Linux) to flash the phone. I get the following error:

Download failed.
Disconnect!
BROM Exception! ( ERROR : STATUS_SEC_IMGHDR_TYPE_MISMATCH (-1073610711) , MSP ERROE CODE : 0x00.

[HINT]:
Verified boot is enabled.
Please download signed image(dtbo_a-verified.img) or disable verified boot.)((exec,../../../flashtool/Cmd/DADownloadAll.cpp,84))

Please help me to disable verified boot or otherwise get past this error so that I can proceed.

Thank you.

Did you unlock your bootloader?

Apparently I did not unlock the bootloader. I just followed your instructions above. In addition to getting the error I noted when running SP Flash Tool, I also get a similar error when trying to boot the phone:

Bad state. Your device has failed verification and may not work properly. Please download boot image with correct signature or disable verified boot. Your device will reboot in 5 seconds.

At that point it reboots over and over, giving me the same message, until I remove the battery.

Will you please give me instructions on how to unlock the bootloader, or have I already destroyed the phone?

Thank you.

I think you have not unlocked your bootloader properly.
Please unlock your bootloader with the process listed here - [ Advanced ] Unlock the Bootloader

After unlocking your bootloader, ensure you have rebooted to system at least once.

Once you have successfully unlocked, flash the build with the instructions provided above. It should boot to system just fine.

For faster support, please join t.me/teracube_oss.

1 Like

The instructions for unlocking the bootloader in the link you posted require me to boot the phone so I can go into Settings to unlock it. Unfortunately my phone won’t fully boot ever since my first attempt to flash Lineage OS. It gives me the error I posted in my previous message and then reboots, over and over until I remove the battery. Is it possible to recover from this?

Please restore the factory firmware first using these steps. Just be careful to use the right firmware image (2022 vs 2021)

Hi there - my turn to have messed up somehow. :sweat:

  • I have the 2022 batch 2e
  • I carefully unlocked the bootloader.
  • I use Linux, so I used SP_Flash_Tool_v5.2152_Linux, which was the latest version I saw on spflashtools.com
  • I used the “hotfix” version of lineage_emerald-SPFlash-eng.gagan.zip (was that my mistake?)
  • The flash completed and I got the big reassuring check-mark at the end

However, now the phone is stuck in fastboot mode and I cannot get it to boot to the OS. If I shut down the phone using the power key, it immediately reboots into fastboot mode. I have to remove the battery to turn it off.

What did I do wrong? And do I now need to restore it to the factory image?

Thank you, I’ll try reflashing the factory firmware. Unfortunately the links to SP Flash Tool are to a Windows version. Can you point me to an official Linux version of SP Flash Tool? (I originally downloaded one from the same website as mick but now I realize that might not be the official website. I don’t know if I can trust that version.)

This is the one I used and I run Xubuntu 20.04. I did have to use How to setup and use SP Flash Tool on Ubuntu 20.04/later/other Distro based on Ubuntu 20.04/later | XDA Forums so that it could use libpng12 instead of the native libpng16. I’m sure there’s something like this for Fedora if needed.

@mmoretz, Did you get error messages before you followed the directions on the XDA forums, or was the behavior as I described (successful completion)? I am running a Debian-based distro. The log files have a few error messages relating to missing sig/cert files and no userdata.img, but that matches gagan’s screenshot and there is nothing in the logs about the png library.

I am a little concerned that the instructions you link to say to run flash_tool.sh as sudo.

The only thing I have found to wonder about is that in the Flash Tool interface, the End Address for super.img is different than the screenshot above, but I figured that was because I was using the updated ‘hotfix’ version.

Yes, you have to run flash_tool as sudo unless you have set up udev rules for /dev/ttyACM0 which is the serial COM port the device uses to communicate with SP Flash Tool.

I was getting errors until I followed the directions on XDA forums to use the SP Flash tool

1 Like

@mick - just to confirm, I tried installing LineageOS hotfix build on Fedora 35 with SPFT 5.2048.0, and it flashed absolutely fine.

You can alternatively try manually flashing these partitions -

fastboot flash boot boot.img
fastboot flash dtbo dtbo.img
fastboot flash vbmeta vbmeta.img
fastboot flash vbmeta_system vbmeta_system.img
fastboot flash vbmeta_vendor vbmeta_vendor.img
fastboot flash super super.img
fastboot -w
fastboot reboot

Please note - fastboot -w will wipe your userdata partition.

Thank you for the clarifications @Gagan.

I figure since it is stuck in fastboot mode anyway, I might as well try the fastboot commands you give. So far, it has been running the first (boot.img) for about 20 minutes now. I’m using a decent quality data cable with a USB3 port. Is that expected behavior?

Looks like the connection timed out. Please reboot to bootloader/fastboot (fastboot reboot bootloader) again and give it a try.
If the command doesn’t work, please try rebooting to bootloader/fastboot using the physical volume buttons on the device, that is, pressing Vol + and Power together until you see the screen with the three options, then navigating to fastboot and pressing Volume Down to select fastboot.

1 Like

Thanks, using the keys was necessary. Trying again.

Something seems wrong, it just keeps hanging. Should I have been doing this in sudo as well? Feel like a dunce… :upside_down_face:

Hmm, unplugging and replugging the cable seems to have done it.
I got:

< waiting for any device >
Sending 'boot_b' (32768 KB)                        OKAY [  0.855s]
Writing 'boot_b'                                   OKAY [  0.446s]
Finished. Total time: 1.318s

…and I apparently have to do that each time. Weird.

:face_with_diagonal_mouth: haha - that ain’t good:

Does the error “Failed to read max minors” mean anything to anybody?

I guess I am going to try restoring the factory image and go from there.