Alarm not waking up screen on Android 11 (1st batch; SN:2020)

One other thing I’ve noticed is that my alarms don’t seem to go off from the default clock app. I tested setting an alarm for 2 min ahead for example and nothing. Any one else?

My alarms are working, but… the screen’s not lit.
I have to manually unlock the phone to shut down the alarm.
Only tested with an alarm set to run just once, on the next day.

Is it the same behavior with the stock clock app (gray color) and Google clock app (blue color)? @Andy_Mc @dboque

Hi Sharad, my clock issue seems to have fixed itself, maybe just part of the update taking a while like others have mentioned? I use the stock app, don’t have the google clock.

1 Like

That was with the stock one, I didn’t even have the other installed.
Now I’ve already installed the blue one (Google Clock app) and set a one time alarm for tomorrow, like I used to do with the stock clock app. I’ll let you know how it goes.

Wow, I’m having this issue along with the other ones I’ve mentioned. I can no longer swipe to snooze or turn the alarm off when the alarm goes off. I have to swipe the alarm open.

So, that’s how it went:

  • at first only stock clock installed, screen kept off when the alarm went off.
  • then installed the Google Clock app, which works fine (screen is lit when alarm goes off).
  • the stock clock keeps working the same (screen not automatically lit).

One other thing is there have appeared 2 clock icons in the notification bar (one at each side of the notch). I’ve noticed it about an hour before the time which the alarm was set on; I think the right side one wasn’t there after just setting it.

  1. @Linda_Le - could you please install the google clock app (link) and confirm if its working good?

  2. I’ll add a Dev bug issue - “Stock app is not waking screen when alarm goes off”.

  3. @dboque - that clock icon on the right side is expected anytime there are active alarms (I just tried it on my phone - both stock and Google clock). The left-side clock icon comes up as a notification saying you have an alarm going off soon.

For all other users (who are reading this thread now), please install Google clock for the time being till we fix the issue in the stock clock app.

1 Like

I downloaded the Google clock app and it works like it’s supposed to.

1 Like

I wanted to chime back in to say I’m having my original issue again.
Today none of my morning alarms went off to wake up. Once I did I set a tester alarm for 2 minutes from the current time and turned the screen back off (as my hunch was that my alarms might only be going off when the phone is in use and screen is on; i.e. my other testers I have watched them go off on screen). Alarm never went off and I have it set to vibrate and full volume. So I think not only does the screen not wake up for the alarm, additionally (at least in my case) if the screen is not already awake the alarm doesn’t go off at all.

Is that with the stock app or Google clock?

Stock, I do not use google clock

ok - we will be troubleshooting the stock clock. Till then, Google clock is a working 1-1 replacement.

I’ve noticed that alarms don’t work when the phone is in battery saver (15% charge left) which is quite unfortunate because the battery drains more quickly since the Android 11 update. :confused:

Everyone - please install the latest 11.0.2 update (either from the Teracube updater inside Android Settings or from the info page). It has few fixes including Google apps, battery and performance.