[Beta] EEA 2 (SW16 - EU) for Teracube 2e

Google Pay not working is “normal” as of now. It is because the build is undergoing certification, and it will start working as soon as certification is done :slight_smile: Let us know if you face any other strange issues.


Unfortunately, I didn’t read the disclaimer and warning exactly enough and didn’t realize it is relevant for Google Pay.
I just wanted to help by using a beta version. Next time I will wait until the final candidate is released.

1 Like

I detected now network issue.
I have to select roaming even in my home network. And in the selection is more for us citizens.

Thanks for the screenshot. This is helpful. Yes - it does seem some US AT&T settings have creeped in.

However, I’m guessing that your usage or billing might continue to be normal? Can you check with your carrier if your billing will be regular?

The reason I ask is because we might take some time to fix this issue.

1 Like

I checked online my data usage and everything is ok.
But to be sure, I try to be always in manual selection of the carrier. Like this, I can avoid being switched to another carrier and pay for roaming.
As you might know, not all countries in Europe are providing roaming without extra cost.
In my case, I have a carrier from Switzerland, and I’m living at the boarder to Austria and Germany. If it switches to a carrier from these countries, I will pay high roaming taxes. To avoid this, it is very useful to block roaming. The second option is to select always manually the carrier.


1 Like

We are looking into this issue. Meanwhile, if it makes sense for you, please revert back to EEA1 using SP Flash.

1 Like

Thanks for your feedback, taking in account my feedback. I can handle the roaming topic and the Google Pay topic for the next few weeks. I will inform you if I see other points not working as usual or expected. Thanks.

1 Like

I just noticed the sound recorder app is gone and I don’t remember deleting it. Could it be a side effect of the update?

1 Like

Raised an internal ticket for this. Potentially missed out in the update.

1 Like

We were waiting for few users to install and give feedback. We will apply for certification by July 26-28 and expect it to be completed by Aug 5-10.

Any news about the release date.


We are running behind on those dates - team is currently fixing the “Roaming” bug that shows the roaming icon for some EU/International carriers. I’ll check and report back.

1 Like

Hi @carepackage17 @Pastis and others who are seeing the roaming icon, could you please help us in diagnosing the roaming issue. Please install this new debug update and share Dev logs from it. This is the same build as EEA 2 with some extra logging.

1 Like

I’m just on my summer holidays. I will install it next week. I hope it will help you.
Should I do something special to report log file or will this work automatically?

Thanks for helping out. Yes next week would work - sooner the better :slight_smile: . Once you run the build and see the unexpected roaming icon, then you can share logs using these steps.

One more ask please. Users who are seeing the Roaming indicator, could you install the original EU build (EEA1) and check if everything is working fine.

Here are the instructions - [Advanced] Installing an Android image w/ SP Flash

Since I’m really looking forward to that update I want to help you test here.
The issue seem to be fixed, at least it’s working for me.
I still was on Teracube_2e_EEA_01_selftest (I always try to stick to release versions) and can confirm that I had no roaming indicator issue here.

Here is what I did:

  • Enter sim
  • Factory reset
  • Reboot
  • Wait for network connection
  • Dev mode → Full bug report (store it somewhere)
  • Update to the debug update you’ve shared
  • Still no Bug - network is working
  • enabled roaming (just for testing)
  • Reboot → still no issue
  • Dev mode → Full bug report

So I now have both bug reports but since I don’t have the issue I guess they are useless for you?

On a sidenote I want to mention that most EU users won’t care about this Roaming indicator bug. I’m 99% sure that there won’t be any additional charges (I had the same issue back in 2015 using a custom rom). Additionally roaming in the EU is mostly free since their fair use policy (it will only affect people on EU borders)

My actual problem is that I need to have android security updates up to date (at least 6 month back). Otherwise the security policy of my company restricts me to use some important apps.

Just curious: what will happen if I use the non-EU version in europe?

I’ve also joined the Telegram group linked here [Beta-Debug] EEA 2-debug Open Test (SW16 - EU) for Teracube 2e if you need any further information.

Thank you very much for your efforts!

I sent you by mail 4 reports.

  1. report in Italy. Real roaming in roaming network an normal to see R and to have extra cost.
  2. report in Switzerland in my home network “Salt” no R visible
  3. report in Switzerland in my home network “Salt” with R visible and data on roaming declined in the phone and no data exchange possible.
  4. report in Switzerland in my home network “Salt” with R visible and data on roaming accepted in the phone and data exchange possible

Network selected manually for 2, 3 and 4 → “Salt”

Screenshot for 3rd report:

Screenshot for 4th report:

1 Like

Before updating to EEA2 I never had the “R” and no issue with “data on roaming” declined in my phone. I always had data exchange possible in my network “Salt”. I always have network selected manually because I’m living close to Austria, and it is switching easy to foreign networks.
Only since EEA2 I have the issue losing data connection when the R is displayed and declined “data on roaming”. (See screenshots in my previous post)

1 Like

I installed original EU build EEA1 and checked it.
It is working everywhere fine (work and home). As long as I’m in logged into my carrier “Salt” I do not see the “R” and I do not need to allow “data at roaming” in the Android settings to have data connection.
If I change to roaming carrier like “A1” from Austria, the “R” is coming and data is blocked as long as not allowed in Android settings. So everything is as it has to be.

1 Like

Thanks @Pastis for confirming this. The Dev team is now working on isolating the carrier code that could be causing issues. Will report once they find something.

1 Like