[Beta] SW13 for Teracube 2e

Update: Please install the new SW15 update.

Summary

** Warning **

  1. Please backup your data before proceeding.
  2. Not for the faint hearted. This is Beta software. If something goes wrong, you might lose your data and might have to re-flash SW6 using SP Flash software.
  3. Few apps might not be available in the App store like Netflix, Disney+ (this is due to the build not yet certified by Google).

Changelog

  1. March 2021 Security updates
  2. AT&T certified

Note: This upgrade is only for US, Canada and other non-EU countries.

Steps

  1. Update. We have a newer Beta build now
  2. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
  3. Goto Settings > System > Teracube Updater
  4. Click top-right 3 dots > Local update
  5. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.
  6. Select the file and continue the update process.
  7. Phone will power off and restart by itself. Don’t press power button.

Let us know how it went and post your questions/feedback here.

If you experience any errors/issues, you can flash SW6 (original firmware) using these instructions.

2 Likes

Thank you, it’s great to see you are working on getting the software of the 2e updated! If things go well with the beta, when do you expect to roll out a production version (for those of us that are not so tech savvy or courageous)?

Actual warnings aside - the Beta SW13 installation is pretty easy. You could wait for some other folks to try and post their experiences :wink:. The production release (via OTA) might take a month or so for the GMS testing.

Updating now, will update with the results. Thanks

Successfully applied the update. Took about 6 minutes to run.

update was simple but one thing i immediately noticed was the camera with some of my apps like when i try to deposit a check for example and take a pic is not able to focus nearly as well as before for some reason.

1 Like

so when will this be final? is there any ballpark? one of the people who have one we bought does not want to install a beta edition because they want to use it for work but they are not allowed to a. run beta or anything other then certified software and b. they cant use it unless the security patches are within a certain updated time frame. so currently the 2e sits as a second phone. i told them about this update for security issues and they were excited till i told them it was a beta release. thanks

1 Like

Expected finalization ~ 1 month.

1 Like

I don’t expect miracles, but any improvement to Bluetooth? Tesla phone key continues to be a daily annoyance, and from its behavior & hints on how other devices act, it seems like the Tesla app monitors the BT signal strength to the various nodes in the car, and uses that data to determine if phone is in range. Either it’s very laggy to update signal stats, or the signal is consistently too low to recognize that the phone is right next to the driver’s door node and put it in unlockable mode. I always have to fiddle with it (bump my pocket to the door while holding the handle open, or get it out and whack it at the center pillar) to get it open. (In this particular case, phone key is the car’s primary intended key - there’s a card for backup that I keep with me, and a fob I can buy - but those are secondary measures.)

Would be nice if it’d just lie to the app and say it’s a stronger signal (add a fixed offset), if the antennas in the 2e are crap :wink: Or if there’s a driver update from the supplier, to at least make sure it’s the latest possible, and maybe push this feedback upstream to them for a potential fix. :smiley:

I suspect it’s a hardware issue, as I also have weak connectivity to my BT earbuds - from head to pocket, it regularly stutters. So that lends to just weak radio in general.

Your timing is perfect. We have a test build ready which does seem to improve Bluetooth signal by 10% or so. If you are willing to give it a shot, download the SW 14 (link) directly on your phone and Follow the same instructions as SW13.

Looking for 2-3 courageous folks who can try this SW14 before we release a wider beta.

2 Likes

I installed it! So far, of the one opportunity I’ve had so far, it’s been better than average - quicker to react to opening the door. Not a representative sample :wink: Then I had a really, really long video call over MS Teams (about 1h:30m) where I mostly used my rear camera to help a remote team member poke and prod a board with a multimeter a few thousand miles away… worked great, with BT audio to my headset, uninterrupted, with the call data going over WiFi.

BT was definitely affected by the update - it asked to re-pair my headset when I used it after installing. That’s a good sign. Will post back later once I get a bit more experience.

1 Like

Downloading SW14 now. Stayed tuned…ran fine. I’ll post any issues I see.

OK, update for one full day’s usage:

  • stability is great. haven’t had a single crash of anything.
  • BT performance is, as you say, improved by about 10% - that is, almost imperceptibly improved.
    • For Tesla phone key, it’s … still pretty big fail, which I’d break down roughly as 80% fail rate, itself consisting of 50%/50% “have to actually get the phone out” / “just have to bump my hip against the car while holding the handle”. 20% actually works within acceptable time frame. Up from 10%, I’d guess with my initial impressions.
    • So far, I’ve had no drops with my headset audio, but I’ve not yet used the problematic earbuds. Jury’s out on that one.
    • I did have to re-pair all Bluetooth devices, which gives weird issues since the device remembers me, but the phone doesn’t. Some have played nicer than others.
  • Installation was a breeze - I just downloaded the zip, then pointed the updater to it. About 10 minutes later, phone just felt like it had rebooted - except my security patch version was now April 2021. Nice little update.
  • Oh thank god, swiping in a generally downward angle on the app launcher no longer flings down the notification drawer. I hadn’t noticed that I hadn’t been bothered by that recently. That’s a good thing. A very good thing.
  • I still feel like using the Gboard is an activity that increases anxiety, as my thoughts run faster than my thumbs can tap - not a problem at a laptop keyboard, but the screen misses a non-trivial number of taps, relying on autocorrect to hopefully fix the missing letters. Autocorrect has a tendency to assume wrong letters more often than missed letters, so it fails to correct properly far more often… maybe it’s the screen protector? Hmm…

Anyway, overall impressions are A+ as an upgrade compared to the current version. Will definitely be keeping this one :slight_smile:

OK, I can now report at least one major issue with the beta: WiFi. Is. Horrible.

It doesn’t last 10 minutes without going into a “coma” state, which is resolved by toggling WiFi off then back on. It shows that it’s connected, but “limited connectivity” and all attempts to make any network connections just … hangs. Even trying to access local resources - hangs.

Not sure what to dig into or what questions to ask to diagnose that much further. This is with a brand new WiFi 6 home internet gateway from T-Mobile - using their shiny new 5G Home Internet service. It’s set to WPA2/WPA3 security, and I have 5GHz and 2.4GHz separated out to different SSIDs since band steering still seems to be little more than a myth. This may also have been an issue with the previous version (I remember having WiFi issues but I never really sat down and ground away at it like I did today).

But yeah, no joke - every 10 minutes, it drops out and goes into a “coma”. Lazy weekend - was on the couch casting YouTube to the TV. After every 10-15 minute video, I’d pop up the phone again, and it’d lose its cast connection and WiFi would be frozen. Have to toggle WiFi off/on to get it shaken loose and reconnect cast, pick another video, carry on, click phone off and absorb a little more useless info from LGR, LTT, Tom Scott, Computer Clan… :nerd_face: Then, video is over, unlock phone, and it’s having another “moment”, rinse and repeat - lost count of it today, but swore I’d write about it. hahaha so here I am

update: found a pattern to it: literally every time I switch off the screen, the WiFi connection becomes unusable/freezes, and has to be toggled off/on to work again.

Lastly, another issue that’s slowly starting to bug the hell out of me: I don’t want the stupid “notification light” on the front of the phone. Ever. At all. It serves no purpose! I always have notifications. I never want to have clear notifications.

I have turned off “blink light”. It’s always been off.

I have also enabled “custom restrictions -> don’t blink light”.

Yet, no matter what I do, the dumb little white light on the front still flashes, constantly, at all times. I can’t find any way to make it stop and cease to exist, short of just straight tearing apart the phone and ripping it off the board. Can y’all please… please find a way to make that notification light behave per the settings?

It is important to determine if the issue is common to the original factory software as well.

Could you please go back to SW6 and test the WiFi again? Keep in mind the process will factory reset your phone by default. If you want to avoid factory reset, then you can uncheck the user data partition in SP Flash software.

I’ll give that a try. The WiFi issues are intense and pervasive. Hopefully I can get away with doing that while avoiding a reset - should be no problem, know my way around such tools :slight_smile:

Will report back later once I get a chance to do it and see the results. Thanks!

BTW, related note - more bad news, the notification-drawer bug still seems present (though not sure why I couldn’t trigger it to slide-down before - it’s happy to glitch-pull the notifications down again now). Auh!

Yeah I had a hunch :slight_smile: since we haven’t fixed it yet.

1 Like

aahhhhhshdhfdsfjlsvlkfjvlsvj~~~

you gigantic trolls. lmao

if (reasonToPullDownNotificationDrawer) break; // shut.png

image

:joy:

Well, that was a :face_with_symbols_over_mouth: mess. I went through the SP Flash tool and left out the “userdata” partition - after getting the driver up and running. The process was not quite as simple as the guide made it seem - after it shows the “happy green checkbox” at the end, the phone was still… just off, dead. Unplugged it and turned it on, and after a couple of flashes of the Teracube logo, I just get a message at a boot-loader screen saying “Can’t load Android system. Your data may be corrupt”. Well, isn’t that great :roll_eyes:

So this beta is quite a one-way process… you can upgrade, but you can’t downgrade. Downgrading requires “basically get a new phone” (that’s what I think of a “factory reset” proposal). So yeah… guess I’m stuck going down that path now :frowning: Was NOT looking forward to a factory reset, but hey, that’s the risk I take with a beta, isn’t it :wink:

update: Factory reset from the error page did the trick, back up and running. Glad I manually took a cloud backup before starting. It restored my launcher pages (phew, was really worried) and seems to be a pretty complete backup - though it’s quite slow to restore apps. I’m OK with this so far. :smiley: