Bluetooth issue with SW16?

My Bluetooth no longer sees other devices. I’ve tried multiple with no success. Other phones can connect to those devices. It worked until recently so I’m thinking maybe something to do with the recent update. Any troubleshooting suggestions?

Hi @Rocky_Gilchrist - welcome to Teracube community. Sorry to hear about your Bluetooth issue. Could you clarify few things please:

  1. Did it not work right after the update? Or did it stop working few days after the update?
  2. Can you check if a reboot helps?
  3. What devices are you trying to connect? Can you do a reset on one of those devices (or remove their pairing) and try again?

I’m going to jump on this thread too, similar issue. I’ve had mixed success with connecting to Bluetooth devices. It happened immediately after the update. It all worked perfectly prior. A reboot did not help. Specifically my Jabra earbuds are undetectable. Pairing has been removed, they still are undetectable by Teracube 2E.

Few things to check and try:

  1. Make sure your Jabra are not connecting to some other phone/computer. Check if there is a way to reset the earphones.

  2. Goto Settings > App & Notifications > See All apps. Select the option to “Show system apps” . Then search for “Bluetooth”. Goto Bluetooth app and Clear Storage & Cache.

  3. If nothing else works, then a factory reset of the phone might be the way to go.

Clearing cache seems to have solved the problem for me. Thanks!

1 Like

Clearing the cache plus resetting the earbuds did it, thanks!

1 Like