Can't set my APN settings properly (Public Mobile, Canada)

Dear Teracube,

I’m trying to connect my new Teracube phone to my Public Mobile network provider, which is a Telus sub-brand (Canada).

Telus seems to be force-pushing its APN settings with some kind of setting-locking flag, which causes newer version of Android to disable the manual editing of APN settings. More info here :

I tried the proposed workarounds, but they don’t seem to be working for Android 9 +; therefore, I can’t get my data working.

This seems to be a manufacturer issue as I think there may be a missing entry in /etc/apns-conf.xml or something like that;

How can I fix this? Should I really need to root my device to edit that file manually?

Thanks

  • Frank
1 Like

Hi Frank,
This does seem to be a special case. Here is a online link I found with similar issue. Could you try this app that is mentioned in there. Let us know how it goes.

We will continue to investigate it on our end as well.

1 Like

Found another way to fix this. Does not involve root but does require ADB over USB.

https://forum.xda-developers.com/showpost.php?p=75157321&postcount=14
(Full XDA thread)

Same solution referenced in Public Mobile’s forums as well : https://productioncommunity.publicmobile.ca/t5/Phones-Hardware/Unable-to-configure-APN-settings/td-p/401346#

1 Like

Hello @Sharad,

Thanks for the quick answer and sorry for the late reply.

Unfortunately, those steps do not work; they only worked in Android versions prior to 9 (those workarounds used “bugs” from those versions to access those settings), but it is impossible from Android 9+ (the bugs were fully patched).

Would it be possible to add Public Mobile to the list of APNs shipped with Teracube phones?

Thanks!

  • Frank

Btw, here is my post on the PM forums : https://productioncommunity.publicmobile.ca/t5/Phones-Hardware/Teracube/td-p/507664

Yes - we will get them added in the next update. Meanwhile - would you be interested in trying out a test build with APN added? The installation steps will use fastboot (similar to the Bootloader unlock section here)

Hello Sharad!

Those are good news, thanks!
Yeah, I’m up for installing a test build; this will perform a factory reset, correct?

Thanks again

  • Frank

Great - should have a test build for you soon. If you have not unlocked your bootloader already, then yes - bootloader unlock will perform a factory reset. Installing the new build will not do a reset by itself.

Question - have you rooted the phone and tried those APN settings? Which APN settings should we add?

Hello Sharad,

Ok cool, I’ll unlock the bootloader as soon as you send me the new build!

I have not rooted my device yet, nor tried the APN settings; I guess you can find the values somewhere on the PM forums. (Somebody posted those values on my post : https://productioncommunity.publicmobile.ca/t5/Phones-Hardware/Teracube/td-p/507664)

Take care!

  • Frank

Hi Frank,

As promised here is the modified system image that includes the Public Mobile APN. Please note that we are not able to test it here (since the particular network is not in US).

  1. Download the image from here. [Update: this points to the 2nd/latest revision as of June 14, 2020].
  2. Unzip it to its img file.
  3. Backup your data (Check under Settings > System > Backup).
  4. Follow these flashing instructions to flash the image to your Teracube.

Let us know how it goes or if you run into anything.

1 Like

This is customer service.

Hey Sharad!

Thanks for the test build; I’ve just installed it, but it unfortunately doesn’t seem to work :S.

The “Network & Internet / Mobile network / Network” setting shows ‘Public Mobile’, but there are no entries in the ‘APNs’ settings page (Where there used to be Telus settings). That page is now blank and shows the following text following text written in “Access Point Name settings are not available for this user”. I’ve tried restarting the device a couple of times, logging in with my google account and playing around with a couple other settings, but I’m not able to make this work (or try out any custom APN settings).

Is there any further troubleshooting info I could give that would be useful to you?

Would it be possible for you to re-enable the manual editing of APNs? I found this reddit post about which commits introduced those changes in the android codebase.

Thanks

  • Frank

We entered the following settings:

<apn carrier=“Public Mobile”
mcc=“302”
mnc=“220”
mmsport=“80”
mmsproxy=“74.49.0.18”
mmsc=“http://aliasredirect.net/proxy/mb/mmsc
apn=“sp.mb.com
type=“default”
/>

The link you gave has slightly different settings. And this another link has slightly different.

Is it possible for you to call Public Mobile and ask them for the right Android settings? Or we can create another build with different settings?

My colleague @robert has put together another test build for you. Will upload and share the the link tomorrow.

Hello Sharad,

I have another phone (Nexus 5X) which connects properly, so here are the snapshots of it’s APN Settings page. I hope it can help!

Take care

- Frank

(Looking forward to that build btw :slight_smile: )

Here you go (new build) . Let us know how it goes. Any screenshots will be helpful.

1 Like

Hi! I just got my Teracube, and am also on public mobile. Also can’t access my data, which I think is the problem on this thread. I could also help if you need another tester, or would love to hear a solution.

It’ll be great if you can try the same instructions and let us know.

ps: I have updated the above instructions with the new image

Hello Sharad,

It still doesn’t work. Here are screenshots of my APN settings page.

I don’t know if it’s worth mentioning, but Public Mobile uses the infrastructure of Telus.

Is there anything else I can do? Some utility I could run?

Thanks!

Is it possible for you to do a root and try out the settings? We added the suggested settings to the apns-conf.xml - so not sure why its not working.

One more thing - can you try a different carrier SIM in this new build. Just to make sure that our apns-conf is working at all or not.