Considering Teracube 2e in US. Is this phone working currently (April 2022) on AT&T?

I’ve loosely watched Teracube, eSolutions, and Lineage OS for some time, but I’m ready to buy one now. However, when I’ve considered a new backup phone lately, I’m reading how turning off 3G on ATT has broken some of the backup phones I’ve considered. Is the Teracube 2e currently working on ATT in the US (as of April 2022)?

ATT provides “discounts” for my family plan, though I confess I’ve not price compared to ensure these discounts are worth it. We live in rural USA and there are big problems with spotty coverage, with ATT seemingly giving us the best coverage, so I don’t want a solution now that requires leaving AT&T.



I can confirm that a person in my household is using a Teracube 2e to connect to AT&T, and has been for quite some time. We’re in the U.S. of A.

I have been using the 2022 batch 2e with LineageOS for a couple of months. My provider is AT&T through Consumer Cellular. It works very well and I’m quite satisfied. The phone is basic and reliable so far.

1 Like

I will say that few users have indeed reported issues with ATT. Here is our latest advisory on this topic.

1 Like

ATT VoLTE(via tracfone) is still not working for me on /e/.
I’ve tried APN settings, and I’ve talked to someone at ATT, but no luck. 3G is still working fine.
/e/ has said that they are working on a fix, so I am hoping that patience will be rewarded.

Good luck!

Ok, so I went with a Murena Teracube 2e and…the data doesn’t seem to work with my AT&T plan. I’m not sure how best to test this to confirm it’s an AT&T issue vs. something I’m doing wrong. I’m able to take a SIM card that works in my Galaxy S9+ and put it into my Teracube 2e. I’m able to call with the phone and I see “AT&T” in the banner bar, but nothing I try with data works. Then, when I turn on wifi, data apps work the way they should.

That sure sounds like a Teracube 2e/3G issue to me. Right?

BTW, I don’t know if I should be posting this on the site as I purchased the Murena phone. Sorry if I’m practicing bad form posting here.

UPDATE: With a reset to the system settings, the phone now shows LTE on the banner and the data are working! Terrific! Thank you @Sharad for your instructions:
Try a soft network reset. Settings > System > Advanced > Reset options.


Glad that its working now @GeneDoc . You could also verify if you are getting VoLTE (aka HD calling). How to check - disable wifi, call someone, see if the LTE indicator stays on during the call.

1 Like