Double tap to wake not working

I noticed there was an issue with tap to wake up. Like for example I would double tap the screen after it’s enabled and nothing happens. I think the issue might be related.

(Moved this to its own topic)

Is it not working at all or sometimes? Have you tried tapping fast? Tap to wake should work all the time.

Tap to sleep only works on the default launcher (won’t work on other launchers like Nova, etc)

Ah that makes sense! I use Niagara launcher. Why is tap to wake launcher specific?

Note - Tap to sleep is launcher specific (Tap to wake works all the time)

Launcher gets all tap inputs and has to call the system sleep method. Hence only default launcher works for sleep.

I noticed that tap to wakes responsiveness is really bad. I have to tap the screen really hard to wake it. However lift to wake works with out any issues.

Did you grant notification access on Niagara launcher? I just installed it on a test unit and the double-tap to wake seems to work fine.

My hunch is that you have some apps running in the background fighting for resources and causing the sluggishness for the double-tap to wake functionality.

PS: The version I installed is 0.18.1 (non Pro version)

I’ll check it out and I’ll let you know.

Yeah, I checked I have notification access.

Will dig into it more on the weekend on my test unit and see what I can find. Are you using fingerprint or PIN to unlock your phone? I also assume you didn’t root your phone is that correct?

Fingerprint and no root.

I ran the test over the weekend with the test unit and didn’t find anything suspicious. The double-tap still works great even this morning.

At this point I don’t have anything to suggest or recommend, sorry. I would like to see the logcat for your phone when the double-tap is not working. If you are comfortable to do that, please send us the log and we can analyze it from our end.

Wait how do I send you the logcat?

If you can get the logcat, you can email it to us as an attachment to

Here are the steps to generate logcat in case you need it:

  1. Install and setup ADB debugging (XDA tutorial link )
  2. Now run “adb logcat” (XDA tutorial )
  3. Please do not share logcat output here since it may have personal data like phone numbers, names, etc. You can email the logs or relevant snapshot to (Refer this forum topic in the email)