EU SIM card issue on 11.0.4?

I’ve been on 11.0.4 for 2 weeks now and everything seemed perfect until I re-enabled my 2nd SIM card that I use when I travel to Switzerland. It shows “No service”, but if I put it into another phone, it works. On my Teracube it shows “No service” even if it’s the only SIM in the phone.

Here are 2 screenshots. My main SIM is “orange” (Romania) roaming via “Salt” or “Swisscom” (Switzerland) and the 2nd SIM is “Sunrise” (Switzerland) which used to work perfectly in April when I was running the default Android 10.

Any thoughts? Thank you!

Hi @silvian86 - could you send us logs (howto) when you have the problem SIM in the phone?

Yeap. Thanks @Sharad . I’ll send it as soon as it’s ready.

Thanks for sharing the logs. Could you check if the non-working SIM card works in the other SIM slot of the 2e?

It doesn’t. I tried that in the past as well. But this time I sent you guys a debug log as well…

1 Like

Can you tell us few things:

  1. What previous Teracube software build were you running and was this network working on it?
  2. What brand and build number is running on the other phone where this SIM is working?

Previously I had the Android 10 build that Teracube 2e came with (I was one of the early ones to get a Teracube 2e)

And the phone in which I tested the SIM and it works is a Google Pixel 6 Pro phone. I assume that one runs the latest Android build…

Maybe it’s worth mentioning: I upgraded from that default Android 10 build directly to 11.0.4 (I didn’t go through any other version (like 11.0.3, for example))

Sorry if you have said this earlier - did the Sunrise SIM work on the Android 10 build?

Yes it did. And it was in the same setup:
SIM1: Orange SIM card, roaming
SIM2: Sunrise SIM

But this was back in April. I’m not from Switzerland, so when I left Switzerland I disabled SIM2 (Sunrise).
In the beginning of September I upgraded to 11.0.4 hoping to get some bugfixes (2e Bluetooth very limited range for example… which still isn’t fixed, unfortunately). And I also had to go back to Switzerland for a business trip. Once I arrived here, I re-enabled SIM2 only to find out it doesn’t work. Not even if I only use the Sunrise SIM card alone in SIM1 slot…

I got home and I was able to do another round of tests:

  • I tested the Sunrise SIM in another phone: it works
  • I tested another SIM in Teracube in the SIM2 slot, alongside my Orange SIM in SIM1. Both SIMs worked

So, my conclusion would be:

  • Teracube’s dual SIM function seems to work fine
  • the Sunrise SIM works (tested in a Google Pixel 6 Pro and in a Huawei Mate 20)
  • Teracube on Sunrise’ network doesn’t work? Is that even a possibility? That they might have a blacklist of some sort?
1 Like

We are comparing A10-SW6 to 11.0.4 specifically for sunrise. Will report back soon.

Possible but we will not conclude that right now.