[Final Beta] Android 12.1 for Teracube 2e (both batches)

Note: Now available for both Zirconia (2020) and Emerald (2021) units (Information about Emerald and Zirconia).

** Warning **

  1. Please backup your data before proceeding.
  2. Not for the faint-hearted. This is Beta software. If something goes wrong, you might lose your data and might have to re-flash factory Android 11.
  3. Read the notes before you install.

Excited to release this final beta of Android 12.1 for T2e. Comes with the latest security patches. Looking for beta testers to help us test it out.
Update: The build is not certified.

What works

  1. Android 12 + April 2023 security update
  2. VoLTE, wifi, and Bluetooth have all been tested
  3. Upgrade from Android 10 and 11 has been tested in the lab
  4. Stable and smooth

Known issues/changes - do read before proceeding

  1. Your wallpaper and home screen will change from what they were on Android 11
  2. Google search bar is docked at the bottom
  3. Vowifi (wifi calling) does not work yet
  4. Build is not certified. Devs are looking into that.

Steps

  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
    Emerald link (SN:2021)
    Zirconia link (SN:2020)

  2. Goto Settings > System > Teracube Updater

  3. Click top-right 3 dots > Local update

  4. Tap “Internal storage” and browse to Downloads or wherever you transferred/downloaded the update zip file.
    Note 1 : If Internal storage does not show anything, then reboot the phone.
    Note 2 : Do not download the update to SD card.

  5. Select the file and continue the update process.
    Note: If the Updater closes or crashes, then try again.

  6. Upgrade process will take a while.

  7. Reboot the phone after the updater says “Update installed”.

Let us know how it went and post your questions/feedback here. Please keep the comments related to this update itself.

If you experience any errors/issues, you can flash the original factory firmware using the automated installer or SP Flash.

8 Likes

I’m pumped to see it available! I will muster the courage to install - no doubt seeing a few success stories here will lower my fear-factor😀

2 Likes

Upgrade from 11 to 12.1 on Emerald was perfectly smooth. No loss of userdata, apps, nor settings (I am using Microsoft Launcher).

Was a bit of a head scratcher to flash back to OEM from /e/, though.

Performance seems good so far, though I’ve not benchmarked it yet.

3 Likes

Upgrade from 11 to 12.1 on Zirconia also was painless and works great :smiley:

Will hopefully get benchmarks PassMark on the weekend.

2 Likes


I tried updating via local updater on the Android 12 Alpha. It doesn’t work because the updater says it’s the same version number.
Can you change the version number so I can try again?

For me it’s Zirconia.

1 Like

Is there an estimated timeline for the final (i.e. non-beta) release of android 12? Thanks.

1 Like

The dev team are taking a look at this issue and will hopefully have an answer/resolution soon.
This should have allowed you to upgrade, so apologies for that.

1 Like

This is as expected - the local update file does not report the build number properly. Just hit OK and it will start installing Beta.

Note: Make sure you have data backup. Going from Alpha to Beta build might require you to do a factory reset and restore (data compatibility). This is only required for A12-Alpha and is not required for all other stock versions.

2 Likes

With help from some testers, we should be able to get it out soon. Vowifi is the main thing that the Dev team is looking into currently.

I do want to add though that this Beta is very stable - I have been personally using it for more than 2 weeks now. If you are on the fence, I’ll suggest give it a try.

5 Likes

Updating from stock Zirconia (most recent non-Alpha update) went very smoothly. No data loss, & so far, so good on everything else. One piece of advice for others updating the same way I did: after updating, search for updates in the Google Play Store. There were about 15 of them, so I updated everything & then restarted. The phone’s been smooth ever since.

5 Likes

That’s great advice for every OS upgrade, as certain app versions are gated by Android version, patches, etc.

Another good thing to check is the Google Play Security Updates in the Security area of settings.

I would hope that these would be part of the post-upgrade done by Android, but it seems not for the time being.

3 Likes

Radio :radio: app missing, chrome browser will not update, update using Zirconia OS, everything is good :blush:

4 Likes

I can confirm the missing FM Radio App.

Does the Play Store give an error for when Chrome fails to update? I can’t reproduce that.

1 Like

For those using Zirconia units (don’t know if Emerald devices are also affected), is the battery drainage problem now resolved?

1 Like

Chrome did update, :+1:t5:, still no radio :pensive:

2 Likes

Okay, I dumped the FM Radio app from my Teracube_One Android 10 ROM using APK Explorer.

I sideloaded it onto both my Zirconia and Emerald Android 12 units and it seems to run fine. I can’t test, however, since I don’t have any headphones at present :expressionless:

It also seems to run fine under /e/OS v1.11, as well.

Use at your own risk, as it requires sideloading from outside of the Google Play Store:
com.android.fmradio.apk (642.8 KB)

Checksums:

MD5 - 0446029b99a4db7e8eb1af62914cc2b3
SHA-1 - 7495a7630fb6f00a7a8f516467c9f7cb7d6a8dd0
SHA-224 - 34fe104dcb16c9367ced73122acc7b7c28115ea3d3190cbe8ad4b189
SHA-256 - 0350c83ff2f991e4cf4c6860ca5f53c16275ce71c9e3e2e7ca07ebb57414ecdc
SHA-384 - f0591331d841d8e4e44af24b80df5601714c8d7f8d48e3d7bb404d7f9b932f7d165315cb54d786ce1ef34cee4935aacb
SHA-512 - ba8a565d82c4334fe2b19cdb3f6b42d2e4a38092f7c65b75efdfec1278419ed978e999cf39ef7d11dc45b6ebdbd8063812163d984df1d68d3caa21e0a9cc2d31
CRC32 - e2d91877

Incidentally, this appears to be the exact same build of FM Radio (AOSP) that shipped in the TeraCube_One Android 12 alpha image, so, I believe this is the most current one (or at the least, the most current one I have access to).

2 Likes

Happy to see progress and Android 12 working in Te2.
I will update as soon as Vowifi (Wi-Fi calling) is fixed. (I need this in our office because mobile network is not working in my office.)

1 Like

Just trying this out, so will update as new things come up but the upgrade from 11 went smoothly.

The only two things I’ve noted so far is that when left plugged in overnight, the battery shows 92% charged and that Google complains that my phone software doesn’t meet security requirements (see screenshot) - it should be noted that my device is not rooted.

2 Likes

Update: The build is showing as not certified. Google Pay will not work.

Regarding the battery - see if that fixes itself over few days.

1 Like