FIngerprint Sensor Failed

My fingerprint sensor seems to have failed with no discernable reason aside from possibly too hot ambient temperature.

I am running the stock v10.1.0 ROM, I have rebooted, I have performed the cache reset multiple times.

I can not get the TeraCube to do an in-place/reflash of the v10.1.0 ROM, so I’m not sure what to try next.

Resetting the phone is not an option as my father just died and I have lost RCS messages in Google’s awful backup during previous resets, and I will not accept losing any of his messages.

Sorry to hear about your father @Saijin_Naib. I’ll suggest you use an SMS backup app, like this one.

I can think of reset as being the only way to figure out if this is a hardware fault or a software glitch.


Thanks, Sharad.

I have a license of SMS Backup Pro, but that (nor anything else) can backup/restore RCS messages, and my family and I have been on RCS exclusively for over a year now, hence my dread of losing his messages.

Does it make sense that an in-place upgrade of v10.1.0 fails early on, or should that go through no matter if I’m already on v10.1.0?

We haven’t tried that - can ask the Dev team to check that. What are you trying to achieve with that?

1 Like

Hoping that I can do it twice in a row to ensure that both A and B partition images are sane and have fresh copies of all files to rule out OS/file-level corruption and see if the functionality of the fingerprint sensor returns.

Barring that… Yeah, looks like reset/new device are my only options.

Dev team said the in-place update should work but will not change anything.

1 Like

Thanks for confirming.

Something is very broken then to have the in-place fail almost immediately each time.

I wonder if the Android Developer/Debug Full-Device backup over USB would preserve RCS messages? I’ll need to test that.

I’m actually having the same problem with my T1. One day last week, after a couple years of working fine, the phone just stopped detecting that it has a fingerprint sensor. Is there any other option than to start a repair ticket?

1 Like

Have you already tried a soft and full reset?

1 Like

Just did a full reset, and the fingerprint reader is still not detected.

1 Like

Then its most likely a hardware issue. Contacting the team is probably the best.