How to install manual update?

@JaimeEatsMusic - we are still testing a few things like the Camera app before we can send the update to everyone automatically.

Regarding finding the downloaded file, see if you are able to find the file using these steps:

  1. Download the upgrade zip file directly on the phone (or transfer the zip to the phone).
  2. Wait for the download to finish. There will be a notification in your phone that shows the download status.
  3. Goto Settings > System > Teracube Updater
  4. Click top-right 3 dots > Local update
  5. The screen that opens might show all the “Recent” files. See if the downloaded file shows in that list.
    5.1 If not in the Recents screen, then tap the top-left menu and tap “Downloads”.
  6. Select the file and continue the update process.
  7. It will take a while. The phone will power off and restart by itself. Don’t press power button.

I appreciate your response, but the file is nowhere to be found. I have downloaded it four times and searched every single folder (system trace, android and subfolders, ddim or whatever it is and sub folders, everything) with “show hidden files” enabled. I have rebooted it multiple times. The file isn’t there and I don’t know what I am doing wrong.
Flashing seems like it is too risky, being unfamiliar with any such process.
My phone doesn’t always register calls, sometimes they just show up as missed, and it doesn’t seem to be a carrier issue. I hoped getting my phone updated would solve the issue, as I now need my phone for work and reliability is crucial.

The update zip file (linked above), I downloaded it on my PC first. Then transferred it into Downloads folder in the phone via USB cable. After that Settings & followed the instructions provided. This way it worked & for me the process was simple. Kindly do it this way & connect your Terracube to the PC. Do reply if any progress have occurred :slight_smile:

I took step-by-step screenshots on how to manually update to Android 11 from the zip file in this post.

  1. Download the zip file from your web browser




  2. Open Settings

  3. Open System

  4. Select Advanced

  5. Select Updater

  6. Select Local Update from the ellipses at the top right.

  7. From the files screen, select the top left hamburger icon and select Downloads


  8. From Downloads, select the zirconia update file

2 Likes

Thanks, I appreciate all the effort you made for me.
When I follow your instructions I am not able to select a folder for download. It just downloads if I tap it or copies the link if I hold it. I tried “Manage Downloads” from the progress bar but it does not let me select a folder either. Everything else goes as pictured, but then it is nowhere to be found in any of those folders.

I also tried connecting my device to my computer to transfer the file that way and it just shows the device as a single listing on the menu of file explorer, and it is blank. There are no sub folders or anything.
When I try to drag and drop the zip file it says “Cannot copy item. The device has either stopped responding or is not connected.” Which is not what I expected or what other users seem to be describing. I got a new cable but the same things happen. I tried the Phone Link app but that seems more focused on messaging and does not let me transfer to folders on my phone.

I am really feeling like an idiot here. Either I am missing something or my phone is defective in some way. I am wondering if I need to make a warranty request, wait for an automatic update, or get a new phone.

Hello Amir. Thank you for responding to me. I tried again with Maiku’s visuals as a guide and it seems to differ for me in that I cannot select a folder, and am still having issues where it does not show up in any folder. As I mentioned in a response to Maiku, when I try to connect my phone to my computer through a c to usb cable, the device appears as a blank folder with no subfolders in it and when I try to move the file from my desktop to my phone it says it cannot be moved as the device is not responding or has been disconnected.
I bought a different cord thinking maybe that was the issue, but no luck.
Is there another way to do this? Is this not how my phone should appear on the computer? Should I unzip the files before moving them to my phone?

I can’t get this to work and I am feeling really dense over here.

Hi @JaimeEatsMusic - your file must be getting downloaded automatically to the “Downloads” folder.

Can you install this screen recording app (link), start a screen capture and perform the update steps. Once done, you can share the screen capture file so that I can check what is going on.

As Sharad has mentioned, by default, files are saved to the Downloads folder. The reason I am able to select a folder is because I am using Brave Browser as my internet browser. What you can do is open the Files app from your apps and then search for “zirconia”.

As for your files not showing up in Windows when connected to your computer. It could be that your phone USB connection is not set to File Transfer mode.

Another possibility is that your phone is locked.

Generally, with most Android phones I have used, I had to select File Transfer mode as well as unlock my phone after connecting my phone to my computer.

1 Like

Good morning.
I made a video using the app you requested, but I cannot post it here, as it is an .mp4, and I am not sure how to change it to another file type. Is there an email I can send it to?

Following Maiku’s advice, I searched “zirconia” (which is the correct version for my batch) in the Files app, but nothing comes up. When I click the file from the download, it also says that the file can’t be opened, so I am not sure if that is something to do with what is going on.

Where are you finding options to do that? The only file sharing options I am seeing in my settings are for nearby devices, and turning that on makes no difference. Nothing pops up on my phone when I connect to my computer, though both my phone and computer ping to acknowledge the connection and my phone folder automatically opens on my computer.