[Certified] Android 11.0.2 for Teracube 2e 1st batch (SN: 2020 / zirconia)

Sure enough - just tried the scan function on the camera app and it froze and crashed. Cycling between other options still works (albeit very slowly), but the minute you select scan it locks up.

Aside from that, it does seem like there are some performance improvements over the first round of 11. Stuff open a bit more quickly, which is nice.

Camera app still buggy, FM radio will not stay open: update to 11.02 today from 10 thanks

Hi @ron77 - welcome to Teracube forums.

Could you try this app - https://github.com/GrapheneOS/platform_external_Camera/raw/12.1/prebuilt/Camera.apk ? We are considering moving to this open source app as our main stock app.

I just tried the FM app. It seems starring any station makes the app crash on all future opens. You can do the following to fix the issue:

  1. Goto Settings > Apps & notifications > See all apps > Search for “FM Radio” app > Tap “Storage & cache”> Clear Storage.
  2. Open FM app again

Thanks for the FM fix, saving station will still cause it to crash. But with the work around it will work :grin::+1:t5:

1 Like

I like how the new camera apk responds👍🏾

1 Like

my wife finally updated to this and her screen is constantly just turning itself on not touching it at all. not lifting it not moving it and its always turning on. anyone else see this? any ideas how to stop it? its driving her crazy. she turned off the double tap, and any other things that turn the screen on by itself and it still is doing it all the time.

I am so frustrated. I cannot get update from 10 to 11.0.2 to work using the local file. It is not anywhere. I keep redownloading it and rebooting me phone, but nothing.
I am not super tech smart and I can’t even manage to figure out where my file is downloading to or find any ability to select where it will go.
I have “shown hidden files” and looked through EVERY SINGLE FOLDER on my phone.

Why do I have to be “an advanced user” to update my phone???
It says to use flash if there are issues but when I go to use flash it warns me not to use flash…
I guess I will just never update my phone?
Thanks for an incredibly frustrating and ultimately futile experience.

Also, there is absolutely nothing that says “Internal storage”
So if someone could help me with this, that would be great. If you guys could make up-dates automatic in the future instead of manual, that would be even better and probably what most users expect when buying a phone.

@mastershake - could you take a video of what’s happening and PM it to me. Also, try a soft reset.

6 posts were split to a new topic: How to install manual update?

I keep getting upgrade failed on T2.

I keep getting upgrade failed as well. I’m on the first batch (North America). any advice?

I tried it from a factory reset android 10.

Could you please take a video from a different phone and share it with me? You can also email it to devs@myteracube.com

to be honest, I would if you had asked me 2 hours ago, but I kinda gave up and installed lineage OS and I do not want to redo all the work I did for the past two hours just to show you the update progress bar hitting approximately the 30% mark and then getting the error screen and then it rebooting into 10.

Unfortunately I too experience dramatic slow down of my phone a few days after upgrading to 11.0.2 (from 10).

Even the last security update for 11.0.2 is from October 2021!
Performance and stability is also really bad (I sometimes even have trouble doing phone calls).

@Sharad: Could you tell us if there’s any plan for further updates? What’s the future for 2e first batch?

I raised this multiple times and got the following response to my latest post.

1 Like

Hi @andineupert A new update for 2e first batch (SN:2020) is already under progress and contains alot of general fixes and optimization, Stay tuned for it :slight_smile:


1 Like

Yes Sir in Year 2030 :joy:

Update: We have 11.0.4 update now.

Please check out 11.0.3 update.