LineageOS on Teracube 2e?

Will there be official support for LineageOS on the 2e, or a way to use a ‘generic’ image without breaking any features? Thanks in advance!

2 Likes

We will start reaching out to Lineage and other custom ROM developers soon (once the initial shipping frenzy gets over). Hope to have some activity in 1-2 months.

Other option is the GSIs which may work right out of the box. However we have not tried them yet.

5 Likes

i’ve recently switched from los to iodéOS, if it gets ported to teracube I’ll certainly buy your hardware ! Thanks for considering custom ROMs

3 Likes

Thanks. I just got my second 2e, which I will use for experiments.

I unlocked the phone and I’m trying to flash Lineage 17.x GSI. I get the error below. Any idea?

C:\PT\fastboot flash system c:\Users\computer\Desktop\platform-tools\lineage-17.1-20210212-UNOFFICIAL-treble_arm64_bvS.img
Sending sparse ‘system’ 1/15 (131068 KB) OKAY [ 3.940s]
Writing ‘system’ FAILED (remote: ‘This partition doesn’t exist’)
fastboot: error: Command failed

(Make sure you have the most up to date fastboot!) You’ll need to go to fastbootd, once you get to recovery, with normal fastboot, type fastboot reboot fastboot, once in fastbootd, you can flash to system. Depending on how big it is, you may need to fastboot delete-logical-partition product. Keep in mind, you should download the recovery images here just in case you mess anything up :slight_smile:

Thanks for the quick response and link to the recovery images. I will try it and post back.

1 Like

Wow. That was fast and painless. The latest Lineage OS 17 GSI build from Andy Yan is now on the phone. It took 133s for the flash.

I’ll play around with it a bit. Looks like I’m getting lots of ‘android.process.media keeps stopping’ errors. I’m new to phone flashing so I expected some issues.

Thanks for the assistance!

Try a factory reset

Yep, that fixed it - Factory reset for the win. As I mentioned, I’m new to this :slight_smile:

You guys are awesome. Thanks

awesome! happy we could get this resolved. LMK how that Lineage GSI works out!

So far so good. Will do!

The thing that’s keeping me from flashing Lineage on my 2e is the fact that I like to have gapps (pico) on there as well, and as far as I saw, I couldn’t figure out a way to do it as I had trouble with getting TWRP on it. Not sure if it’s possible to do with the stock teracube bootloader. Any ideas? :slightly_smiling_face:

I’m not particularly qualified to provide support on these topics, as noted above :slight_smile:

But I looked at the lineageos gapps wiki and noticed one thing that really stuck out - good luck!

https://wiki.lineageos.org/gapps.html

Installation

Google apps should be installed via recovery immediately after installing LineageOS. Exact steps vary, and as such, you should see your device’s installation guide here for specific instructions.

warning

IMPORTANT: If you reboot into LineageOS before installing Google apps, you must factory reset and then install them, otherwise expect crashes.

I’m a couple days in and all seem fine so far. I noticed a weird slow-down @ https://lineageos.org/ when you scroll down toward the bottom where it says “Longevity”, but haven’t observed anything similar elsewhere yet.

On YouTube it freaked out when going full screen, but once I was able to confirm the full screen warming, it was fine.

Tunein APK installs and works despite warning that google play services are missing. Opera browser works great. No gapps or play services are installed (and won’t be).

Hi Sampson. Thanks for responding.

I’m looking more for a tutorial on how to flash this with the stock Teracube recovery/fastboot instead of TWRP, though I may just give flashing TWRP another go. :stuck_out_tongue:

Hey @Sampson - could you write a mini howto on how to get Lineage GSI onto 2e?

2 Likes

I would also like to use lineage OS on my teracube 2e. I do really hope that teracube 2e will get official support for lineage… this would allow a fast update/patch cycle.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.